Subject: Re: How to return seto records from seof record function?

From: Laurenz Albe <[email-masked]>
Date: Tue, 25 Feb 2025 15:47:23 +0100

On Tue, 2025-02-25 at 17:15 +0300, Олег Самойлов wrote:
> Postgresql 17.2
> 
> How to return seto records from seof record function? I tried pg_background extension:
>  
> CREATE OR REPLACE FUNCTION public.autonomous (p_script text)
> RETURNS SETOF record
> LANGUAGE plpgsql
> VOLATILE STRICT PARALLEL UNSAFE
> AS $autonomous$
> DECLARE
> l_id integer;
> BEGIN
> l_id := pg_background_launch(p_script);
> RETURN QUERY SELECT * FROM pg_background_result(l_id) AS (r record);
> END;
> $autonomous$;
>  
> SELECT * FROM autonomous('SELECT now()') AS (a timestamptz);
>  
> SQL Error [42804]: ERROR: structure of query does not match function result type
>   Detail: Returned type record does not match expected type timestamp with time zone in column 1.
>   Where: SQL statement "SELECT * FROM pg_background_result(l_id) AS (r record)"
> PL/pgSQL function autonomous(text) line 6 at RETURN QUERY

You need to be specific:

  SELECT * FROM pg_background_result(l_id) AS (col1 integer, col2 text, ...);

I don't think there is a way to get a generic "record" as result.
And even if you could, you would still have to specify a column list
when you call autonomous().

Attempts to write functions with polymorphic return type are usually futile.

Perhaps you can return a "SETOF jsonb"...

Yours,
Laurenz Albe

---

From: Merlin Moncure <[email-masked]>
Date: Wed, 26 Feb 2025 17:31:56 -0600

> Perhaps you can return a "SETOF jsonb"...

There is only one non-jsonb method I'm aware of to convert string query to
result without specifying result structure, and that's via refcursors,
something like:
begin;
BEGIN;

CREATE FUNCTION f() RETURNS TEXT AS
$$
DECLARE
  r REFCURSOR DEFAULT 'test';
BEGIN
  OPEN r FOR EXECUTE $z$SELECT 'a' AS a, 1 AS b$z$;
  RETURN r;
END;
$$ LANGUAGE PLPGSQL;

SELECT f();

FETCH test;
...

..I doubt it works in OP's case though as this only works to push all the
way back to the client app. but it's a neat artifact from yore.

In modern postgres, I think jsonb is the way to go.  Function output syntax
is one of the clunkiest parts of the language, you are on a freight train
to deep dynamic SQL; it sure would be nice if we could somehow pass an
output definition somehow in a way the calling function or query could
use.  This mostly comes up in my experience with analytics, where the
column needs are very dynamic and layered.

merlin