Subject: Re: insufficient privilege with pg_read_all_stats granted

From: Pavel Luzanov <[email-masked]>
Date: Wed, 21 Aug 2024 11:24:43 +0300

On 21.08.2024 10:50, Pavel Luzanov wrote:
> But I don't understand why it worked in v14.
> Probablysomethinghas changed,  butIcouldn't quicklyfindwhatexactly.

Ifoundit.
https://github.com/postgres/postgres/commit/6198420a

-- 
Pavel Luzanov
Postgres Professional:https://postgrespro.com

---

From: Costa Alexoglou <[email-masked]>
Date: Wed, 21 Aug 2024 17:07:09 +0200

> I think the problem is in the NOINHERIT attribute for the abcd role.

Indeed that is the issue, thanks for helping find this out