Subject: Re: Regarding publish_via_partiton_root with pglogical

From: Durgamahesh Manne <[email-masked]>
Date: Sat, 28 Sep 2024 11:09:51 +0530

Hi

Any inputs from the PGDG team members regarding this ?

Regards
Durga Mahesh

On Mon, Jul 22, 2024 at 3:35 PM khan Affan <[email-masked]> wrote:

> Hi Durgamahesh
>
> In pglogical extension, there is no direct equivalent to the
> publish_via_partition_root option found in the built-in logical replication
>
> you can achieve similar results when a new partition is added; you must
> add it to the replication set using pglogical.replication_set_add_table.
> Similarly existing partitions are reorganized or split, ensure to update
> the replication sets accordingly.
>
> Thanks & Regards
>
>
> *Muhammad Affan (*아판*)*
>
> *PostgreSQL Technical Support Engineer** / Pakistan R&D*
>
> Interlace Plaza 4th floor Twinhub office 32 I8 Markaz, Islamabad, Pakistan
>
> On Sat, Jul 20, 2024 at 12:00 PM Durgamahesh Manne <
> [email-masked]> wrote:
>
>> Hi
>>
>> Respected Team
>>
>> I know the use case of implementing the partitions with publication and
>> subscription of built-in logical replication
>> CREATE PUBLICATION dbz_publication FOR TABLE betplacement.bet WITH
>> (publish_via_partition_root = true); This will use parent table to replica
>> data changes to target from source
>> But
>> Could you please provide a logic to implement the same with pglogical ?
>> Do i need to add this publish_via_partition_root to
>> pglogical.replication_set_add_table functionality ?
>> you response is valuable in this aspect
>>
>> Regards,
>> Durga Mahesh
>>
>

---

From: Greg Sabino Mullane <[email-masked]>
Date: Sat, 28 Sep 2024 11:00:34 -0400

Please do not spam the mailing lists with requests for follow ups. In this
particular case, you received an answer two days after you posted it. It
went to both psql-general, pgsql-in-general, and to you directly, so there
seems little excuse for missing it.

Also note that pglogical is a third-party extension and as such you may
have more success in the future asking the maintainers of it via its github
page (as I see you have done, although in a somewhat impolite way:
https://github.com/2ndQuadrant/pglogical/issues/487)

Cheers,
Greg

---

From: Durgamahesh Manne <[email-masked]>
Date: Sat, 28 Sep 2024 22:25:29 +0530

Hey Greg

Thank you

Regards,
Durga Mahesh