Subject: Move pgBackrest repo?

From: "Colin 't Hart" <[email-masked]>
Date: Wed, 14 Jan 2026 16:24:37 +0100

Hi all,

What is the best way to move a pgBackrest repo?

It was configured as /var/lib/pgbackrest, but we want to move it to
/data/pbackrest to get it off the root partition.

It is being written to continually by archivers from several servers. Since
access is over ssh, there's no server component that we can just stop for
the duration.

Thanks,

Colin

---

From: Greg Sabino Mullane <[email-masked]>
Date: Wed, 14 Jan 2026 11:29:29 -0500

> What is the best way to move a pgBackrest repo?

* rsync to get things mostly copied
* use 'pgbackrest stop' to prevent it from running
* verify no pgbackrest processes still going
* update the conf file to point to the new dir
* final rsync
* rename the old repo dir so nothing writes to it by accident
* use 'pgbackrest start'

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support