Subject: Re: Effects of REVOKE SELECT ON ALL TABLES IN SCHEMA pg_catalog FROM PUBLIC

From: Tom Lane <[email-masked]>
Date: Thu, 12 Sep 2024 00:36:45 -0400

Andreas Joseph Krogh <[email-masked]> writes:
> Motivation: I have PowerBI users, with a separate ‘reporting’-role, accessing 
> a database and I want to prevent them from listing all tables, users, databases 
> and view-definitions (to not see the underlying query).

Postgres is not designed to support this requirement.

> I'm evaluating this:
> REVOKE SELECT ON ALL TABLES IN SCHEMA pg_catalog FROM PUBLIC; REVOKE SELECT ON 
> ALL TABLES IN SCHEMA information_schema FROM PUBLIC;
> Will this affect “normal behaviour”, ie. prevent the planner, or other 
> internal mechanisms, from working properly for sessions logged in with the 
> ‘reporting’-role?

Probably 95% of that stuff will still work.  By the same token, there
are plenty of information-leaking code pathways that will still leak.
For instance, your restricted user will have no trouble discovering
the OIDs and names of all extant tables, using something like

do $$ begin
for tid in 1..1000000 loop
  if tid::regclass::text != tid::text then
    raise notice 'tid % is %', tid, tid::regclass;
  end if; end loop;
end $$;

Functions such as pg_describe_object still work fine, too.

Experimenting with psql, a lot of stuff is broken as expected:

busted=> \d mytable
ERROR:  permission denied for table pg_class

but some things still work:

busted=> \sf sin
CREATE OR REPLACE FUNCTION pg_catalog.sin(double precision)
 RETURNS double precision
 LANGUAGE internal
 IMMUTABLE PARALLEL SAFE STRICT
AS $function$dsin$function$

This is pretty much the other side of the same coin.
The reason you can still parse and plan a query is that
it does not occur to large parts of the backend that there
should be any reason to refuse to read a system catalog.
That carries over to these operations as well.

This recent thread might be enlightening:

https://www.postgresql.org/message-id/flat/18604-04d64b68e981ced6%40postgresql.org

If you have a requirement like this, I think the only safe
way to meet it is to not give those users direct SQL access.
Put some kind of restrictive app in front of the database.

			regards, tom lane

---

From: Brent Wood <[email-masked]>
Date: Thu, 12 Sep 2024 04:48:23 +0000

Could you use FDW's in another completely separate db for them to access so they have no direct access to the source data (or database), only the linked tables which have no local data, other users, etc,  present at all?

Which is sort of what was suggested: "Put some kind of restrictive app in front of the database." This other db could be that app?

Brent Wood

Principal Technician, Fisheries
NIWA
DDI:  +64 (4) 3860529

________________________________
From: Tom Lane <[email-masked]>
Sent: Thursday, September 12, 2024 16:36
To: Andreas Joseph Krogh <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: Effects of REVOKE SELECT ON ALL TABLES IN SCHEMA pg_catalog FROM PUBLIC

do $$ begin

busted=> \d mytable

busted=> \sf sin

https://www.postgresql.org/message-id/flat/18604-04d64b68e981ced6%40postgresql.org<https://www.postgresql.org/message-id/flat/18604-04d64b68e981ced6%40postgresql.org>

                        regards, tom lane

[https://www.niwa.co.nz/static/niwa-2018-horizontal-180.png] <https://www.niwa.co.nz/>
Brent Wood
Principal Technician - GIS and Spatial Data Management
Programme Leader - Environmental Information Delivery
+64-4-386-0529

National Institute of Water & Atmospheric Research Ltd (NIWA)
301 Evans Bay Parade Hataitai Wellington New Zealand
Connect with NIWA: niwa.co.nz<https://www.niwa.co.nz/> Facebook<https://www.facebook.com/nzniwa> LinkedIn<https://www.linkedin.com/company/niwa> Twitter<https://twitter.com/niwa_nz> Instagram<https://www.instagram.com/niwa_science> YouTube<https://www.youtube.com/channel/UCJ-j3MLMg1H59Ak2UaNLL3A>
To ensure compliance with legal requirements and to maintain cyber security standards, NIWA's IT systems are subject to ongoing monitoring, activity logging and auditing. This monitoring and auditing service may be provided by third parties. Such third parties can access information transmitted to, processed by and stored on NIWA's IT systems.
Note: This email is intended solely for the use of the addressee and may contain information that is confidential or subject to legal professional privilege. If you receive this email in error please immediately notify the sender and delete the email.

---

From: Andreas Joseph Krogh <[email-masked]>
Date: Thu, 12 Sep 2024 06:51:54 +0200 (CEST)

Thanks for info.

I know PG is not designed for this, but I have this requirement nonetheless…
I think preventing “most users and tools" from seeing/presenting this 
information is “good enough”.
Maybe not revoking access to all the tables in the schemas, but the “most 
obvious ones”, like pg_user, pg_shadow, pg_tables etc. will suffice.

If read-access (SELECT) on views in public-schema will still works, and 
pg_dump/restore etc. also works, this sounds like a solution to me.

--
Andreas Joseph Krogh
CTO / Partner - Visena AS
Mobile: +47 909 56 963
[email-masked] <mailto:[email-masked]>
www.visena.com <https://www.visena.com>
 <https://www.visena.com>

På torsdag 12. september 2024 kl. 06:36:45, skrev Tom Lane <[email-masked] 
<mailto:[email-masked]>>:

do $$ begin

busted=> \d mytable

busted=> \sf sin

regards, tom lane

---

From: Greg Sabino Mullane <[email-masked]>
Date: Thu, 12 Sep 2024 09:05:48 -0400

> information is “good enough”.

As pointed out, there are very many workarounds. This is security theater.

> pg_dump/restore etc. also works, this sounds like a solution to me.

pg_dump will absolutely not work without access to the system catalogs.

If you want to prevent information, stop direct access and make the
application call user functions.

(Also note that determining if a database or user exists does not even
require a successful login to the cluster.)

Cheers,
Greg

---

From: Dominique Devienne <[email-masked]>
Date: Thu, 12 Sep 2024 15:11:59 +0200

On Thu, Sep 12, 2024 at 3:06 PM Greg Sabino Mullane <[email-masked]> wrote:
> (Also note that determining if a database or user exists does not even require a successful login to the cluster.)

Hi. How so? I was not aware of such possibilities.
Can you please give pointers (docs, examples) of this?

Thanks, --DD

---

From: Andreas Joseph Krogh <[email-masked]>
Date: Thu, 12 Sep 2024 15:21:49 +0200 (CEST)

På torsdag 12. september 2024 kl. 15:05:48, skrev Greg Sabino Mullane <
[email-masked] <mailto:[email-masked]>>:

On Thu, Sep 12, 2024 at 12:52 AM Andreas Joseph Krogh <[email-masked] 
<mailto:[email-masked]>> wrote:

Yes, it is theater, but that doesn't prevent “compliance people” to care about 
it. We have to take measures to prevent “information leaks”.

---

From: Greg Sabino Mullane <[email-masked]>
Date: Thu, 12 Sep 2024 09:53:02 -0400

> Can you please give pointers (docs, examples) of this?

$ psql -U eve
psql: error: connection to server on socket "/tmp/.s.PGSQL.5432" failed:
FATAL:  role "eve" does not exist

$ psql -U postgres -d theater
psql: error: connection to server on socket "/tmp/.s.PGSQL.5432" failed:
FATAL:  database "theater" does not exist

$ psql -U alice -d template1
psql: error: connection to server on socket "/tmp/.s.PGSQL.5432" failed:
FATAL:  password authentication failed for user "alice"

Cheers,
Greg