Subject: Re: Guarantee order of batched pg_advisory_xact_lock

From: Tom Lane <[email-masked]>
Date: Wed, 11 Feb 2026 17:49:57 -0500

Nico Heller <[email-masked]> writes:
> So it would probably be better to ORDER BY the hashtextended result 
> instead of :keysToLock, right?

Yeah, that seems like it'd work, if you have no other dependencies
on the locking order.

			regards, tom lane

---

From: Nico Heller <[email-masked]>
Date: Thu, 12 Feb 2026 11:18:34 +0000

I just checked for hash collisions with the following query today:

SELECT COUNT(*), hashtextextended(key, 0) FROM
(
   SELECT key FROM table1
   UNION
   SELECT key FROM table2
   UNION
   ...
) keys (key)
GROUP BY hashtextextended(key, 0)
HAVING COUNT(*) > 1

Where table1, table2, ... are all the tables we are acquire keys from to 
use for the mentioned query.

Sadly, no results were returned. Thus, I can rule out hash collisions.

Any other thoughts? Here is an error log from the JDBC driver:

org.postgresql.util.PSQLException: ERROR: deadlock detected Detail: 
Process 60780 waits for ExclusiveLock on advisory lock 
[24605,3030106527,494580150,1]; blocked by process 65280.
  Process 65280 waits for ExclusiveLock on advisory lock 
[24605,1321834016,1311356115,1]; blocked by process 60780.

On 2/11/26 23:49, Tom Lane wrote:
> Nico Heller<[email-masked]> writes:

---

From: Greg Sabino Mullane <[email-masked]>
Date: Thu, 12 Feb 2026 09:47:39 -0500

> SELECT COUNT(*), hashtextextended(key, 0) FROM

FWIW, you need UNION ALL, not UNION, if you are trying to detect duplicate
values (hashed or not) across tables.

Cheers,
Greg

---

From: Nico Heller <[email-masked]>
Date: Mon, 16 Feb 2026 17:45:30 +0000

Does anyone have any idea what the root cause of my issue is? I 
appreciate any insight.
As I said, hash collisions can be rules out, sadly.

On 2/12/26 12:18, Nico Heller wrote:
> Where table1, table2, ... are all the tables we are acquire keys from 
> to use for the mentioned query.
>

---

From: Greg Sabino Mullane <[email-masked]>
Date: Tue, 17 Feb 2026 09:55:30 -0500

On Mon, Feb 16, 2026 at 12:45 PM Nico Heller <[email-masked]> wrote:

> Does anyone have any idea what the root cause of my issue is? I appreciate
> any insight.

Well, you could set log_statement to 'all' for a bit to see *exactly* what
each of the deadlocking processes are doing. Alternatively, perhaps you can
write a hashextendedkey() function that outputs arguments and results to a
log and/or a table.

keysToLock is a text[] parameter which is pre-sorted in our application

Would not hurt to triple-check this part as well. Could show us the app
code? Maybe put in some sort of global assert in the app to verify that
things are indeed sorted as you think they are.

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support

---

From: Nico Heller <[email-masked]>
Date: Wed, 18 Feb 2026 21:19:36 +0000

On 2/17/26 15:55, Greg Sabino Mullane wrote:
> Well, you could set log_statement to 'all' for a bit to see *exactly* 
> what each of the deadlocking processes are doing. Alternatively, 
> perhaps you can write a hashextendedkey() function that outputs 
> arguments and results to a log and/or a table.
I will give that a shot, thank you
> Would not hurt to triple-check this part as well. Could show us the 
> app code? Maybe put in some sort of global assert in the app to verify 
> that things are indeed sorted as you think they are.
I am 100% sure this is the case, as the code base isn't huge and we have 
central component which is *always* used to acquire advisory locks.
It looks as follows, in pseudo Kotlin code:

class LockingRepository(val sqlClient: SqlClient) {

     @Transactional(propagation = MANDATORY) // enforces a transaction 
is already active, using pg_advisory_xact_lock is senseless otherwise
     fun acquireLocks(keys: List<String>) = 
sqlClient.query(<QUERY_HERE>).param(:keys, sort(keys)).execute()

     private fun sort(keys: List<String>) = keys.sort() // as I said, 
it's sorted in some arbitrary way

}