Subject: PostgreSQL Active-Active Clustering

From: "Sarkar, Subhadeep" <[email-masked]>
Date: Mon, 15 Jul 2024 19:06:06 +0000

Hi,

We are evaluating features of the Community edition of PostgreSQL in relation to a proposal for a prospective client and need help with the queries below:-

  *   Does the Community edition of PostgreSQL provide NATIVE active-active high availability clustering with objectives of scalability, load balancing and high availability without using any extensions or external components or usage of Kubernetes/Dockers.

  *   In the Community edition of PostgreSQL is it possible to setup a database cluster in load balancing mode and provide vertical and horizontal scalability without repartitioning or changes to the database objects or 3rd party transaction routing mechanisms using NATIVE features only (i.e. without using any extensions or external components or usage of Kubernetes/Dockers).

  *   In the Community edition of PostgreSQL is it possible to setup  a cluster where all the nodes are able to concurrently read-write the underlying database image using NATIVE features (i.e. without using any extensions or external components or usage of Kubernetes/Dockers).

Kindly direct us to the right contributor/user group. Thanks in advance!

Regards,
Subhadeep

Subhadeep Sarkar
Program Director
Government & Public Service - Technology.

O +91 33 4403 4000
M +91 98301 69398

Email: :[email-masked]<mailto:[email-masked]>

KPMG Advisory Services Private Limited
Unit No. 604, 6th Floor, Tower 1, Plot No. 5,
Block DP, Godrej Waterside, Sector V,
Salt Lake,
Kolkata - 700 091

**********************************************************************
________________________________________
KPMG (in India) allows reasonable personal use of the e-mail system. Views and opinions expressed in these communications do not necessarily represent those of KPMG (in India).

*******************************************************************************************************
DISCLAIMER
The information in this e-mail is confidential and may be legally privileged. It is intended solely for the addressee. Access to this e-mail by anyone else is unauthorized. If you have received this communication in error, please address with the subject heading "Received in error," send to [email-masked], then delete the e-mail and destroy any copies of it. If you are not the intended recipient, any disclosure, copying, distribution or any action taken or omitted to be taken in reliance on it, is prohibited and may be unlawful. Any opinions or advice contained in this e-mail are subject to the terms and conditions expressed in the governing KPMG client engagement letter. Opinions, conclusions and other information in this e-mail and any attachments that do not relate to the official business of the firm are neither given nor endorsed by it.

If this email is being sent by a KPMG team member deployed with a client in relation to KPMG’s engagement with such client for supporting the client through deployment of a team as per the requirement of the [Work Order/Letter of Award/Purchase order/Contract] and such team member is working under the client’s supervision and control, then the respective client is responsible for the content of this email and/or attachments to the email regardless of whether such team member is using client/project domain ID or that of KPMG.

If this email is received by Government Authority on a public email IDs (like gmail, yahoo etc.), then it should be noted that this was sent on public email ID since KPMG was not provided with an alternate secure email ID by the recipient. It is highlighted to the recipient that Government guidelines have advised not to use public emails and an alternate secure email id in line with Government IT Security policy should be provided to KPMG for further communications. KPMG will not be responsible for any situations which may arise on account of using public email id by such recipient.

KPMG cannot guarantee that e-mail communications are secure or error-free, as information could be intercepted, corrupted, amended, lost, destroyed, arrive late or incomplete, or contain viruses.

KPMG, an Indian partnership and a member firm of KPMG International Cooperative ("KPMG International"), an English entity that serves as a coordinating entity for a network of independent firms operating under the KPMG name. KPMG International Cooperative (“KPMG International”) provides no services to clients. Each member firm of KPMG International Cooperative (“KPMG International”) is a legally distinct and separate entity and each describes itself as such.
*******************************************************************************************************

---

From: "David G. Johnston" <[email-masked]>
Date: Mon, 15 Jul 2024 12:20:27 -0700

On Mon, Jul 15, 2024 at 12:06 PM Sarkar, Subhadeep <[email-masked]>
wrote:

>
> We are evaluating features of the Community edition of PostgreSQL in
> relation to a proposal for a prospective client and need help with the
> queries below:-
>
>
>
>    - Does the Community edition of PostgreSQL provide NATIVE
>    active-active high availability clustering with objectives of scalability,
>    load balancing and high availability without using any extensions or
>    external components or usage of Kubernetes/Dockers.
>
>
Basically, no.  See "logical replication" if you'd like to delve into why I
qualified this one.

>
>    - In the Community edition of PostgreSQL is it possible to setup a
>    database cluster in load balancing mode and provide vertical and horizontal
>    scalability without repartitioning or changes to the database objects or
>    3rd party transaction routing mechanisms using NATIVE features only (i.e.
>    without using any extensions or external components or usage of
>    Kubernetes/Dockers).
>
>
No

>    - In the Community edition of PostgreSQL is it possible to setup  a
>    cluster where all the nodes are able to concurrently read-write the
>    underlying database image using NATIVE features (i.e. without using any
>    extensions or external components or usage of Kubernetes/Dockers).
>
>
>
No

There is only one server process per underlying data directory in
PostgreSQL.

David J.

---

From: Christophe Pettus <[email-masked]>
Date: Mon, 15 Jul 2024 22:38:46 -0700

> On Jul 15, 2024, at 12:06, Sarkar, Subhadeep <[email-masked]> wrote:
> 
>  • Does the Community edition of PostgreSQL provide NATIVE active-active high availability clustering with objectives of scalability, load balancing and high availability without using any extensions or external components or usage of Kubernetes/Dockers. 
> 
>  • In the Community edition of PostgreSQL is it possible to setup a database cluster in load balancing mode and provide vertical and horizontal scalability without repartitioning or changes to the database objects or 3rd party transaction routing mechanisms using NATIVE features only (i.e. without using any extensions or external components or usage of Kubernetes/Dockers).
> 
>  • In the Community edition of PostgreSQL is it possible to setup  a cluster where all the nodes are able to concurrently read-write the underlying database image using NATIVE features (i.e. without using any extensions or external components or usage of Kubernetes/Dockers).

I do have to add that this list of requirements sounds very much like a set supplied by the sales organization of a commercial database vendor (in fact, a particular commercial database vendor) in order to exclude open-source software.  Open-source software relies very much on a whole ecosystem, rather than attempting to deliver every imaginable feature in the core distribution.  This is especially true of projects like PostgreSQL which are not backed by a single company and do not have an official commercial distribution.  Can your client articulate why they need these specific features, and why they must be in the core distribution?