Subject: Re: Transaction issue

From: "David G. Johnston" <[email-masked]>
Date: Wed, 19 Jun 2024 14:55:32 -0700

On Wednesday, June 19, 2024, Adrian Klaver <[email-masked]>
wrote:

> On 6/19/24 14:33, Rich Shepard wrote:
>
>> On Wed, 19 Jun 2024, Adrian Klaver wrote:
>>
>> I should have added to previous post:
>>> What is the exact command string you are using to launch psql?
>>>
>>
>> $ psql bustrac
>>
>
> I find it difficult to believe that actually runs.
>
> psql -d test -U postgres -bustrac
>
> psql: hint: Try "psql --help" for more information.

You hallucinated a dash in front of the bustrac.  psql bustract is a
perfectly valid psql command.  User gets inferred from the OS user.

David J.

---

From: Rob Sargent <[email-masked]>
Date: Wed, 19 Jun 2024 16:14:06 -0600

> perfectly valid psql command.  User gets inferred from the OS user.
Oh no.  Adrian is an AI?!!

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 19 Jun 2024 17:16:19 -0700

On 6/19/24 14:55, David G. Johnston wrote:
> On Wednesday, June 19, 2024, Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 

As in?:

psql -d test -U postgres  bustrac
psql: warning: extra command-line argument "bustrac" ignored
psql (16.3 (Ubuntu 16.3-1.pgdg22.04+1), server 15.7 (Ubuntu 
15.7-1.pgdg22.04+1))
Type "help" for help.

test=#

In which case bustrac is ignored.

-- 
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 19 Jun 2024 17:18:46 -0700

> Oh no.  Adrian is an AI?!!

No, I am perfectly capable of providing incorrect answers solely on the 
basis of my 'little gray cells'.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 19 Jun 2024 17:27:03 -0700

> psql -d test -U postgres  bustrac

Well no, that is the specification of -U is the exact opposite of "user
gets inferred from the OS user".

> In which case bustrac is ignored.
You are missing the fact that bustrac is the name of the database so when
you specify the -d option you are being redundant and being told that by
psql.

psql [option...] [dbname [username]]

You like to specify both dbname and username via options but as shown one
can also use arguments.

David J.

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 19 Jun 2024 17:30:34 -0700

On 6/19/24 17:27, David G. Johnston wrote:
> On Wed, Jun 19, 2024 at 5:16 PM Adrian Klaver <[email-masked] 
> You are missing the fact that bustrac is the name of the database so 
> when you specify the -d option you are being redundant and being told 
> that by psql.
> 

Yep, completely missed that.

> 
> You like to specify both dbname and username via options but as shown 
> one can also use arguments.
> 
> David J.
>