Subject: Re: Getting error "too many clients already" despite having a db connection limit set

From: Adrian Klaver <[email-masked]>
Date: Mon, 16 Jun 2025 10:21:39 -0700

On 6/16/25 09:29, adolfo flores wrote:
> Hello Team,
> 
> I hope you can help me with an issue we're experiencing. We have an app 
> running on Kubernetes that opens a huge number of connections within a 
> couple of seconds.
> 
> The database that the app connects to, is configured with a connection 
> limit of 30% of the max_connections setting. Despite this limit being 

I am not understanding the above. The connection limit from the database 
side is going to be the value for max_connections. It is not clear to me 
what "...  connection limit of 30% of the max_connections setting" is 
referring to?

I suggest providing the actual numbers you are working with as well as 
the locations where the numbers are being set.

> set for that database, we're seeing the following errors in the 
> PostgreSQL logs:
> 
> FATAL:  sorry, too many clients already
> FATAL:  remaining connection slots are reserved for roles with the 
> SUPERUSER attribute
> 
> 
> Is it expected behavior to reach the max_connections limit when that app 
> opens many connections in a short period of time, even if a connection 
> limit is set for that database and everything else uses no more than 10% 
> of the max_connections?
> 
> Or any idea on what could be happening?
> 
> 
> Regards.
> 
> Adolfo F.

-- 
Adrian Klaver
[email-masked]

---

From: "David G. Johnston" <[email-masked]>
Date: Mon, 16 Jun 2025 11:09:59 -0700

> what "...  connection limit of 30% of the max_connections setting" is

See "alter database ... set"

David J.

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 16 Jun 2025 11:13:25 -0700

> See "alter database ... set"

Aah, forgot about that.