Subject: Stess test via libpq for postgreSQL DB

From: Sasmit Utkarsh <[email-masked]>
Date: Sat, 27 Apr 2024 23:37:20 +0530

Hi Postgresql Team,

Could you please help on how to get started with some stress test for my
application which uses libpq to interact with postgres flexi db. I tried to
explore pgbench which is a builtin tool to get some stats. But i have some
clarifications if we can use it to execute PLSQL code blocks rather than
standalone SQL queries. Please advise

Regards,
Sasmit Utkarsh
+91-7674022625

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 27 Apr 2024 11:14:12 -0700

On Sat, Apr 27, 2024 at 11:07 AM Sasmit Utkarsh <[email-masked]>
wrote:

>
> But i have some clarifications if we can use it to execute PLSQL code
> blocks rather than standalone SQL queries.
>

https://www.postgresql.org/docs/current/sql-do.html

David J.

---

From: Sasmit Utkarsh <[email-masked]>
Date: Sun, 28 Apr 2024 00:53:03 +0530

Thanks David

Regards,
Sasmit Utkarsh
+91-7674022625