Subject: Re: Default values in the docs

From: Adrian Klaver <[email-masked]>
Date: Fri, 27 Feb 2026 07:47:47 -0800

On 2/26/26 10:43 PM, Igor Korot wrote:
> Hi, ALL,
> The page at https://www.postgresql.org/docs/current/sql-createtable.html#SQL-CREATETABLE-STORAGE-PARAMETERS
> does not document the default
> values for all storage parameters.

The only ones that are not covered from what I see are fillfactor and 
parallel_workers.

The settings that cover items in postgresql.conf have defaults shown here:

https://www.postgresql.org/docs/current/runtime-config.html

As example the default for:
	vacuum_truncate, toast.vacuum_truncate
		Per-table value for vacuum_truncate parameter.
can be found here:
	https://www.postgresql.org/docs/current/runtime-config-vacuum.html#GUC-VACUUM-TRUNCATE
> 
> Is this an oversight or intentional?
> 
> Thank you.
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: "David G. Johnston" <[email-masked]>
Date: Fri, 27 Feb 2026 08:58:07 -0700

Trimming excess content...

On Fri, Feb 27, 2026 at 8:48 AM Adrian Klaver <[email-masked]>
wrote:

> > The page at
> https://www.postgresql.org/docs/current/sql-createtable.html#SQL-CREATETABLE-STORAGE-PARAMETERS

fillfactor: The fillfactor for a table is a percentage between 10 and 100.
100 (complete packing) is the default.

parallel_workers: If not set, the system will determine a value based on
the relation size.

I don't think including the algorithm for parallel_workers would be
appropriate for the documentation.

Hence, both are indeed "covered".

David J.