Subject: an error message that I don't understand

From: Martin Mueller <[email-masked]>
Date: Fri, 2 May 2025 20:24:52 +0000

I get this error message:

table tid from new index tuple (32586,21) overlaps with invalid duplicate tuple at offset 120 of block 4398 in index "aacorrections_tcpreading_idx"

from an update query of the
update table 1 set columnx = ‘yes’
where table1.xmlid in (select xmlid from table2)

I have no idea what is going on or how to deal with it and will be grateful for advice

---

From: "David G. Johnston" <[email-masked]>
Date: Fri, 2 May 2025 13:45:38 -0700

On Fri, May 2, 2025 at 1:25 PM Martin Mueller <
[email-masked]> wrote:

>
> table tid from new index tuple (32586,21) overlaps with invalid duplicate
> tuple at offset 120 of block 4398 in index "aacorrections_tcpreading_idx"
>

Read that as "your index is corrupted".

> I have no idea what is going on or how to deal with it and will be

You will need to rebuild the index.

If you've recently performed an OS upgrade you may also wish to update
most/all indexes to fix possible collations issues.

David J.