Subject: Re: pgbackrest after a network outage unable to perform backup [fails always]

From: Greg Sabino Mullane <[email-masked]>
Date: Tue, 24 Feb 2026 10:49:30 -0500

On Tue, Feb 24, 2026 at 5:18 AM KK CHN <[email-masked]> wrote:

> This goes for hours now, not yet finished. Is this normal behaviour ?
>

Yes, if there is a lot of WAL

My goal is to initiate a full backup afresh on the reposerver , so it
> doesn't matter all the old piled up WAL files
>

You will need to (carefully!) disable pgbackrest archiving, clean up the
old WAL, then start it up again. Basic sequence:

1. Set archive_command to '/bin/true'
2. Kill any existing pgbackrest processes, empty out the spool directory
3. Wait for Postgres to cleanup / recycle the WAL (speed up with a manual
CHECKPOINT)
4. Restore your archive_command to the pgbackrest version
5. Run pgbackrest check to verify WALs are being archived again
6. Run a full backup

Ideally, test these steps on a dev system, and understand why each step and
why in that order. :)

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support

---

From: KK CHN <[email-masked]>
Date: Wed, 25 Feb 2026 12:56:55 +0530

On Tue, Feb 24, 2026 at 9:20 PM Greg Sabino Mullane <[email-masked]>
wrote:

> Ideally, test these steps on a dev system, and understand why each step
> and why in that order. :)
>

Thank  you  Greg .