Subject: Re: ProcSignalBarrier and ITC Issue

From: Adrian Klaver <[email-masked]>
Date: Thu, 22 May 2025 17:19:15 -0700

On 5/22/25 12:43, Brahmaiah psql wrote:
> Hi Postgres Community,
> 
> I Face error the ProcSignalBarrier and IPC
> 
> When we are dropping the database, it is not dropped. Also, the database 
> is not connecting. The log file shows this error(LOG: still waiting for 
> backend with PID 4077 to accept ProcSignalBarrier). Now how to debug 
> this error. please support any one to this error.

This is going to need a lot more information, for a start:

1) Postgres version.

2) Is the community version or a fork/hosted version?

3) The client being used and the complete query/command/code that is 
dropping the database.

4) The complete log message.

> Thank you,
> Brahmaiah K

-- 
Adrian Klaver
[email-masked]

---

From: Torsten Förtsch <[email-masked]>
Date: Fri, 23 May 2025 11:33:17 +0200

Could be this one:
https://www.postgresql.org/message-id/CA%2BkvmZELXQ4ZD3U%3DXCXuG3KvFgkuPoN1QrEj8c-rMRodrLOnsg%40mail.gmail.com

Should be fixed in 15.2