Subject: Re: verify checksums online

From: Greg Sabino Mullane <[email-masked]>
Date: Sat, 19 Apr 2025 11:29:42 -0400

On Fri, Apr 18, 2025 at 5:18 PM Jeremy Schneider <[email-masked]>
wrote:

> but i wanted to confirm with someone - my easiest options for online
> verifying checksums would be to trigger pg_basebackup then check
> pg_stat_database, or to install michael's utility?
>

Your easiest option is to just use pgbackrest, which verifies checksums as
part of its process. So you are guaranteed to have every page verified at
least as often as every full backup.

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support

---

From: Vijaykumar Jain <[email-masked]>
Date: Sun, 20 Apr 2025 00:21:05 +0530

iirc there used to be a Google snippet that did online checksum
verification. it worked pretty well , but I did not let it run the tests of
the extension, so it may not be 100% , I just used it for a quick check if
there were other problems visible.

if it's archived now well :)

https://github.com/google/pg_page_verification

Thanks,
Vijay

Open to work
Resume - Vijaykumar Jain <https://github.com/cabecada>