Subject: Pg_basebackup failed or completed?

From: jayesh thakare <[email-masked]>
Date: Mon, 25 Nov 2024 11:09:39 +0530

Hi Team,

We have got below error while doing basebackup

pg_basebackup: could not close file "000000020000022E000000027": No error

Can we assume that backup is completed successfully?

Regards,
Jayeshthakare
Postgresql DBA
8828986182

---

From: ajit wangkhem <[email-masked]>
Date: Mon, 25 Nov 2024 13:38:56 +0530

Put wal log in the restore directory and check during start postgresql
consumed or not. If consumed then no issue. Instead of risk free create
recovery.conf or standby.signal and put restore_command in that above file
and see whether consumed or not. If consumed its ok.