Subject: Re: Windows installation problem at post-install step

From: Ertan Küçükoglu <[email-masked]>
Date: Mon, 22 Jul 2024 15:22:34 +0300

Sandeep Thakkar <[email-masked]>, 22 Tem 2024 Pzt, 15:01
tarihinde şunu yazdı:

>
> When I checked the installation log shared by Ertan, I do see that the
> locale passed to initcluster script is the same as returned by the
> getlocales executable.
>
> Executing C:\Windows\System32\cscript //NoLogo "C:\Program
> Files\PostgreSQL\16/installer/server/initcluster.vbs" "NT
> AUTHORITY\NetworkService" "postgres" "****"
> "C:\Users\User1\AppData\Local\Temp/postgresql_installer_cd79fad8b7"
> "C:\Program Files\PostgreSQL\16" "C:\DATA_PG16" 5432 "Turkish,Türkiye" 0
>

That is log file line no 5544 and is cscript logging. There is no problem
here.
If you check log file line no 5606 you will see that the encoding is not
correct just before initdb
Maybe this is related to BAT file usage? I don't know.

Thanks & Regards,
Ertan

---

From: Sandeep Thakkar <[email-masked]>
Date: Mon, 22 Jul 2024 18:10:21 +0530

On Mon, Jul 22, 2024 at 5:52 PM Ertan Küçükoglu <[email-masked]>
wrote:

> Sandeep Thakkar <[email-masked]>, 22 Tem 2024 Pzt,
> 15:01 tarihinde şunu yazdı:
>
>>
> Ah, I see it now. Let me take a closer look

-- 
Sandeep Thakkar

---

From: Sandeep Thakkar <[email-masked]>
Date: Fri, 2 Aug 2024 18:14:50 +0530

>> Ah, I see it now. Let me take a closer look

That line gets printed from within the initdb and is not printed by the
script.
@Thomas Munro <[email-masked]>  I may be wrong but I guess fixing
the code might fix this.
Can you please share your patch so that I apply it on top of the last
released
source version, generate the installer and confirm the behaviour?

-- 
Sandeep Thakkar

---

From: Sandeep Thakkar <[email-masked]>
Date: Mon, 5 Aug 2024 14:20:10 +0530

Hi Thomas,

This issue is seen only on v16 and not the back branches (tested on 15 and
14) and also confirmed by @Ertan Küçükoglu <[email-masked]> at
https://github.com/EnterpriseDB/edb-installers/issues/127#issuecomment-2268371442

On Fri, Aug 2, 2024 at 6:14 PM Sandeep Thakkar <
[email-masked]> wrote:

>> On Mon, Jul 22, 2024 at 5:52 PM Ertan Küçükoglu <
>> [email-masked]> wrote:
>>
>>> That is log file line no 5544 and is cscript logging. There is no
>>> problem here.

-- 
Sandeep Thakkar