Subject: Re: Pgpool with high availability

From: Adrian Klaver <[email-masked]>
Date: Tue, 28 May 2024 11:01:20 -0700

On 5/28/24 1:31 AM, vijay patil wrote:
> 
> HI Team,
> 
> "I'm encountering challenges while configuring Pgpool with high 
> availability. The initial setup is completed, and Pgpool is operational 
> on a single node, functioning without issues. However, upon attempting 
> to start Pgpool on any additional nodes, particularly node 2, it becomes 
> immediately unreachable.

And how we are supposed to arrive at an answer with essentially no 
information provided?

Need:

1) Configuration for initial setup.

2) A more detailed explanation of what "... upon attempting
to start Pgpool on any additional nodes" means? Include configuration 
changes.

3) The error messages.

4) Where the nodes are located?

> 
> I'm seeking assistance to address this issue. My setup consists of three 
> nodes, each hosting both PostgreSQL and Pgpool services."
> 
> 
> Thanks
> 
> Vijay
> 

-- 
Adrian Klaver
[email-masked]

---

From: Muhammad Imtiaz <[email-masked]>
Date: Wed, 29 May 2024 10:28:18 +0500

Hi,

Can you please provide the Pgpool logs? Additionally, in a distributed
environment, ensure that Pgpool is properly configured. You can follow
these documented steps to set up the Pgpool configurations
pgpool.conf,pcp.conf and pool_hba.conf .

Regards,
Muhammad Imtiaz