Subject: Re: tds_fdw >> Install Foreign data Wrapper on EDB Postgres to connect to SQL server database

From: Ian Lawrence Barwick <[email-masked]>
Date: Wed, 29 May 2024 09:27:30 +0900

2024年5月29日(水) 6:10 Sumit Kochar <[email-masked]>:
>
> Installation of Foreign data Wrapper on EDB Postgres to connect to SQL server database is not working.
>
>
>
> https://github.com/tds-fdw/tds_fdw/issues/357
>
>
>
> Please advise if this has been encountered or a workaround is available.
(...)

> [root@hostip tds_fdw-2.0.3]# make USE_PGXS=1 install
>
> /opt/rh/llvm-toolset-7/root/usr/bin/clang -Wno-ignored-attributes -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2  -I./include/ -fvisibility=hidden  -I. -I./ -I/usr/edb/as13/include/server -I/usr/edb/as13/include/internal -I/usr/libexec/edb-icu66/include/ -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include -flto=thin -emit-llvm -c -o src/tds_fdw.bc src/tds_fdw.c
>
> make: /opt/rh/llvm-toolset-7/root/usr/bin/clang: Command not found

IIRC you'll need to find and install the SCLO package for Oracle Linux
7, assuming it's
available. For CentOS it's this repository:
http://mirror.centos.org/centos/7/sclo/ .

Regards

Ian Barwick

---

From: Muhammad Imtiaz <[email-masked]>
Date: Wed, 29 May 2024 08:43:11 +0500

Hi ,

You need to install the  LLVM toolset.

1)Check that if it is installed or not :

yum list installed | grep llvm-toolset

2)If it is not installed, you can install it using the following command.
sudo yum install llvm-toolset-7

Regards,
Muhammad Imtiaz

On Wed, 29 May 2024 at 05:27, Ian Lawrence Barwick <[email-masked]>
wrote:

> > /opt/rh/llvm-toolset-7/root/usr/bin/clang -Wno-ignored-attributes
> -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2
> -I./include/ -fvisibility=hidden  -I. -I./ -I/usr/edb/as13/include/server
> -I/usr/edb/as13/include/internal -I/usr/libexec/edb-icu66/include/
> -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include -flto=thin -emit-llvm
> -c -o src/tds_fdw.bc src/tds_fdw.c
> >