Subject: Re: Bash profile

From: Yongye Serkfem <[email-masked]>
Date: Sat, 15 Feb 2025 14:17:00 -0500

I am upgrading from version 12.7 to 15.7

On Sat, Feb 15, 2025, 2:15 PM Ron Johnson <[email-masked]> wrote:

> On Sat, Feb 15, 2025 at 2:01 PM Yongye Serkfem <[email-masked]> wrote:
>
>> Hi Everyone!
>> I would appreciate any assistance with configuring the bash profile to
>> run two different postgresql versions. Specifically V12.7 and 15.7
>>
>
> Create a bash function that exports PGDATA to the relevant directory,
> based on the parameter you pass.
> Add as much error checking (to ensure that the parameter you passed
> actually points to a real data dir and that the postmaster is running.  How
> you do that depends on whether it's Debian-based, RH-based or something
> else.
>
> We, for example, have standardized on data directories in the format:
> /Database/<MajorVer>/data
>
> Thus, something as simple as this would work for us:
> pgswitch() { export PGDATA=/Database/${1}/data ; }
>
> --
> Death to <Redacted>, and butter sauce.
> Don't boil me, I'm still alive.
> <Redacted> lobster!
>

---

From: Ron Johnson <[email-masked]>
Date: Sat, 15 Feb 2025 16:02:56 -0500

So?

Honestly, your question has zero to do with Postgresql.  Its basic Linux
configuration.

Before the migration, PGDATA and PATH should point to the v12 "stuff", and
after the migration they should point to the v15 "stuff".  It's that simple.

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 15 Feb 2025 13:09:35 -0800

> I am upgrading from version 12.7 to 15.7

You are going to have to explain what, in your situation, BASH has to do 
with the upgrade process. Generally migrations depend on Postgres 
programs and are not shell specific.

> 
> 
> On Sat, Feb 15, 2025, 2:15 PM Ron Johnson <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     On Sat, Feb 15, 2025 at 2:01 PM Yongye Serkfem <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Hi Everyone!
>         I would appreciate any assistance with configuring the bash
>         profile to run two different postgresql versions. Specifically
>         V12.7 and 15.7
> 
> 
>     Create a bash function that exports PGDATA to the relevant
>     directory, based on the parameter you pass.
>     actually points to a real data dir and that the postmaster is
>     running.  How you do that depends on whether it's Debian-based,
>     RH-based or something else.
> 

-- 
Adrian Klaver
[email-masked]