Subject: Index rebuilding strategy

From: Siraj G <[email-masked]>
Date: Thu, 25 Sep 2025 02:12:05 +0530

Hello Experts!

What are the top pointers we should consider for index rebuild? Check its
size,  bloat estimate, heavy Updates/Deletes?

Please highlight the best practices.

Thanks
Siraj

---

From: Alban Hertroys <[email-masked]>
Date: Wed, 24 Sep 2025 22:50:56 +0200

> On 24 Sep 2025, at 22:42, Siraj G <[email-masked]> wrote:
> 
> Hello Experts!
> 
> What are the top pointers we should consider for index rebuild? Check its size,  bloat estimate, heavy Updates/Deletes?
> 

I think just any pointers of corruption, really. OS updates with differing collation implementations, known flaky hardware or driver issues, checksum discrepancies if you have those turned on and get any of those.

The need to rebuild indices should be quite rare. Regular vacuuming and analysing should take care of most of the need, with much of those happening automatically anyway (could need some tuning though).

Regards,
Alban Hertroys
--
If you can't see the forest for the trees,
cut the trees and you'll find there is no forest.

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 24 Sep 2025 23:52:55 +0200

> What are the top pointers we should consider for index rebuild? Check its size,  bloat estimate, heavy Updates/Deletes?

https://www.cybertec-postgresql.com/en/should-i-rebuild-my-postgresql-index/

Yours,
Laurenz Albe

---

From: Ron Johnson <[email-masked]>
Date: Wed, 24 Sep 2025 19:34:03 -0400

On Wed, Sep 24, 2025 at 4:51 PM Alban Hertroys <[email-masked]> wrote:

> > What are the top pointers we should consider for index rebuild? Check
> its size,  bloat estimate, heavy Updates/Deletes?
> >
> I think just any pointers of corruption, really. OS updates with differing
> collation implementations, known flaky hardware or driver issues, checksum
> discrepancies if you have those turned on and get any of those.
>
> The need to rebuild indices should be quite rare. Regular vacuuming and
> analysing should take care of most of the need, with much of those
> happening automatically anyway (could need some tuning though).
>

I drop the scale factors down to 1.5% and the insert threshold to 500.  The
application we run seems to like that.  YMMV, of course.

autovacuum_analyze_scale_factor = 0.015
autovacuum_vacuum_scale_factor = 0.015
autovacuum_vacuum_insert_scale_factor = 0.015
autovacuum_vacuum_insert_threshold = 500

Also, I repack tables when abs(correlation) gets below 60% (which
eventually happens on tables where the oldest records are regularly
deleted).  That rebuilds the indices for you.

(Why don't I partition those tables?  1. It's a 3rd party application;
thus, they control the schema. 2. Partitioning by date means adding a date
field to the PK, which means the PK really isn't a PK anymore.)

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!