Subject: RE: License question

From: "Clay Jackson (cjackson)" <[email-masked]>
Date: Mon, 25 Nov 2024 22:47:07 +0000

Christophe is spot on when it comes to the PostgreSQL software.

Not trying to be "snarky" or condescending, but there are some other considerations.   "Open Source" or "Free" does not mean "without cost".

No matter where you decide to host the software, there will be storage, compute, and network costs, not only to support the software itself, but also the data you store.

With respect to the data, since you or your employer have decided to persistently store the data in a database, I would presume the data, and more importantly, access to that data, has value.

It seems from the original post that you've decided to pay someone (a cloud vendor) to "take care" of the storage, network, and compute "services".  That's great!

But, what about that "non-licensed" software?   Once you use that software to store and access your data, you have created a CONTINUING need for that software.   What will it cost you or your employer if a "bug" in that software prevents access to, or worse yet, corrupts your data.

Are you willing to sign up for "maintaining" PostgreSQL in your environment, INCLUDING things like patching, finding and fixing bugs, upgrades, backup and recovery, and off-hours support?  If you or your employer have any concerns about this, and IHMO, you should, you might want to consider a "licensed and supported" version of PostgreSQL.  There are several out there, including EDB and others.  Even the big cloud vendors have "support plans" for PostgreSQL.

Oh, and don't forget, a backup only as good as the last time you tested a restore.

Clay Jackson
Database Solutions Architect
[email-masked]

-----Original Message-----
From: Christophe Pettus <[email-masked]>
Sent: Monday, November 25, 2024 11:59 AM
To: prashant sinha <[email-masked]>
Cc: [email-masked]
Subject: Re: License question

CAUTION: This email originated from outside of the organization. Do not follow guidance, click links, or open attachments unless you recognize the sender and know the content is safe.

> On Nov 21, 2024, at 21:40, prashant sinha <[email-masked]> wrote:
> Is there a free version of PostgreSQL available which I can use without buying any licenses? In case I want to self install and manage the database? Just need guidance if I can install the available version from site for business purpose too or I must buy licenses? Will appreciate an appropriate related answer.

PostgreSQL itself is an open source project distributed under a very permissive license:

        https://www.postgresql.org/about/licence/

No payment is required to download and run it.

---

From: Ron Johnson <[email-masked]>
Date: Mon, 25 Nov 2024 20:05:43 -0500

On Mon, Nov 25, 2024 at 5:47 PM Clay Jackson (cjackson) <
[email-masked]> wrote:
[snip]

> Are you willing to sign up for "maintaining" PostgreSQL in your
> environment, INCLUDING things like patching, finding and fixing bugs,
> upgrades, backup and recovery, and off-hours support?

Azure's Postgresql managed database handles all that (except off-hours
support) for you, and there's much less off-hours support required (at
least there was with AWS RDS Postgresql, so pressuming so with Azure, too).

Of course, OP just mentioned an Azure VM, so he'd have to do all that
himself.

Using the Azure Postgresql managed database still means you'll have to
think about archiving data, and properly configuring PG (mainly autovacuum
parameters).

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: "Clay Jackson (cjackson)" <[email-masked]>
Date: Tue, 26 Nov 2024 01:20:22 +0000

Thanks, Ron!   Exactly my points!

I do not want to “discount” the community in ANY way.    In fact, I’m a huge fan of Open Source, as long as everyone, including “management”, is bought into community support concept.

I’ve seen the “wrong side” of “What do you mean, ‘You posted something to the list’?   Why can’t you CALL someone (and/or get someone logged in) RIGHT NOW?” discussions, usually “in the heat of battle”,  a few too many times.

Of course, the flip side of this is “Whew – the community solved this before the <large software support organization> even got back to me”.

It comes down to being “fully informed”.

Clay Jackson

From: Ron Johnson <[email-masked]>
Sent: Monday, November 25, 2024 5:06 PM
To: pgsql-general <[email-masked]>
Subject: Re: License question

On Mon, Nov 25, 2024 at 5:47 PM Clay Jackson (cjackson) <[email-masked]<mailto:[email-masked]>> wrote:
[snip]
Are you willing to sign up for "maintaining" PostgreSQL in your environment, INCLUDING things like patching, finding and fixing bugs, upgrades, backup and recovery, and off-hours support?

Azure's Postgresql managed database handles all that (except off-hours support) for you, and there's much less off-hours support required (at least there was with AWS RDS Postgresql, so pressuming so with Azure, too).

Of course, OP just mentioned an Azure VM, so he'd have to do all that himself.

Using the Azure Postgresql managed database still means you'll have to think about archiving data, and properly configuring PG (mainly autovacuum parameters).

---

From: Alan Hodgson <[email-masked]>
Date: Mon, 25 Nov 2024 17:42:52 -0800

On Mon, 2024-11-25 at 22:47 +0000, Clay Jackson (cjackson) wrote:
> environment, INCLUDING things like patching, finding and fixing
> bugs, upgrades, backup and recovery, and off-hours support?
> 

Not sure what your point is, you have to do all that with commercial
software, too. And at least with open source you actually can find
and patch bugs yourself, in theory, although you certainly don't have
to, not with any major project.