Subject: Re: get speed help

From: Ron Johnson <[email-masked]>
Date: Mon, 19 May 2025 12:43:42 -0400

Spinning rust?  SSD?  NVMe? SATA? SCSI?  Fiber?

Anyway... off the cuff, for 1 giga-rows, that's about a 50GB table.  Small
enough that you can easily test that yourself.

On Mon, May 19, 2025 at 12:38 PM Dias Thomas <[email-masked]> wrote:

> Hello,
> 1 field 20 chars plus primary key id field - small table
> indexed on that char - 20 field , say 16 gb ram, amd normal power processor
> no parallel processing, to know it, the speed in single processor
>
> On Mon, May 19, 2025 at 9:55 PM Ron Johnson <[email-masked]>
> wrote:
>
>> On Mon, May 19, 2025 at 12:12 PM Dias Thomas <[email-masked]>
>> wrote:
>>
>>> Hello all,
>>>  Could i get a help, postgres 1 billion records indexed table, search
>>> speed in a normal machine, no parallel processing ... for a knowledge ??
>>>
>>
>> 1. How big are the records?
>> 2. How big are the keys?
>> 3. What is a normal machine?
>> 4. Why no parallel processing?
>>
>> --
>> Death to <Redacted>, and butter sauce.
>> Don't boil me, I'm still alive.
>> <Redacted> lobster!
>>
>

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Ron Johnson <[email-masked]>
Date: Mon, 19 May 2025 15:05:51 -0400

Ok?

Honestly, your questions puzzle me: PG is open source, binaries are
available for Windows, every Linux distro, and even BSD.  And *the database
is pretty small*.

Install it, and *test it yourself*.

Then you'll have the answer.

On Mon, May 19, 2025 at 12:57 PM Dias Thomas <[email-masked]> wrote:

> Hi,
> I mean any manual
>  I have a small code, that searches some 10000 billion records in 1
> seconds thru index simple case -- I want to test that with postgres
>
>
> On Mon, May 19, 2025 at 10:14 PM Ron Johnson <[email-masked]>
> wrote:
>
>> Anyway... off the cuff, for 1 giga-rows, that's about a 50GB table.
>> Small enough that you can easily test that yourself.
>>