Subject: WAL settings for larger imports

From: "Benoit, Eric" <[email-masked]>
Date: Mon, 17 Jun 2024 13:46:06 +0000

What is a good data import configuration for only one server for WRITE-AHEAD LOG settings postgresql.conf where no one is connecting to the database accept me as a superuser.

Confidentiality Notice: This electronic message and any attachments may contain confidential or privileged information, and is intended only for the individual or entity identified above as the addressee. If you are not the addressee (or the employee or agent responsible to deliver it to the addressee), or if this message has been addressed to you in error, you are hereby notified that you may not copy, forward, disclose or use any part of this message or any attachments. Please notify the sender immediately by return e-mail or telephone and delete this message from your system.

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 17 Jun 2024 08:10:11 -0700

On 6/17/24 06:46, Benoit, Eric wrote:
> What is a good data import configuration for only one server for 
> WRITE-AHEAD LOG settings postgresql.conf where no one is connecting to 
> the database accept me as a superuser.

1) The Confidentiality Notice is longer then the question and is 
basically pointless.

2) An answer is going to need more information:

a) Postgres version?

b) What are your current settings?

c) What constitutes a 'larger import'?

d) How often are you doing these imports?

-- 
Adrian Klaver
[email-masked]

---

From: Ron Johnson <[email-masked]>
Date: Mon, 17 Jun 2024 11:57:30 -0400

On Mon, Jun 17, 2024 at 9:46 AM Benoit, Eric <[email-masked]> wrote:

> WRITE-AHEAD LOG settings postgresql.conf where no one is connecting to the
> database accept me as a superuser.
>

How worried are you about data loss / database corruption?

Is streaming or logical replication enabled?