Subject: Re: pg_restore failed on foreign key constraint

From: Ron Johnson <[email-masked]>
Date: Fri, 13 Feb 2026 11:40:42 -0500

On Fri, Feb 13, 2026 at 11:14 AM Adrian Klaver <[email-masked]>
wrote:

> On 2/13/26 08:05, Ron Johnson wrote:
> > On Fri, Feb 13, 2026 at 10:55 AM Adrian Klaver
> > <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >     On 2/13/26 06:18, Ron Johnson wrote:
> >      > On Fri, Feb 13, 2026 at 1:43 AM Laurenz Albe
> >     <[email-masked] <mailto:[email-masked]>
> >      > <mailto:[email-masked]
> >     <mailto:[email-masked]>>> wrote:
> >
> >      > Turns out that there's a nightly cron job that dumps this (and
> >     other)
> >      > tables with the "--data-only --disable-triggers" options and then
> >     does
> >      > "psql -Xaf mumble.sql" to load them into this database.
> >      >
> >      > But access_email_id=2073 is in the source access_email, so I've
> >     got to
> >      > figure out why it's not being loaded into the target.
> >
> >     Is it in the dump file from the source?
> >
> >
> > Some tables aren't being dumped at the source;  Thus, the missing
> records.
>
> Un-confuse me, how do the below relate?:
>
> "Turns out that there's a nightly cron job that dumps this (and other)
> tables with the "--data-only --disable-triggers" options and then does
> "psql -Xaf mumble.sql" to load them into this database.
>
> But access_email_id=2073 is in the source access_email, so I've got to
> figure out why it's not being loaded into the target."
>
> and
>
> "Some tables aren't being dumped at the source"
>

Table name            Source Dumped   Target Loaded
public.access_email   No              No
public.rel_user_email Yes             Yes

Thus, while new and modified records are being added to public.access_email
at the source, they are not making it to the Target database.  That plus
"--disable-triggers" lets the public.rel_user_email loads succeed on the
target even though it breaks RI.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 13 Feb 2026 09:35:31 -0800

On 2/13/26 8:40 AM, Ron Johnson wrote:
> On Fri, Feb 13, 2026 at 11:14 AM Adrian Klaver 

> Thus, while new and modified records are being added 
> to public.access_email at the source, they are not making it to the 
> Target database.  That plus "--disable-triggers" lets 
> the public.rel_user_email loads succeed on the target even though it 
> breaks RI.

This means you know what the issue is now?

---

From: Ron Johnson <[email-masked]>
Date: Fri, 13 Feb 2026 15:17:36 -0500

On Fri, Feb 13, 2026 at 12:35 PM Adrian Klaver <[email-masked]>
wrote:
[snip]

> This means you know what the issue is now?

Yes it does. 😀