Subject: Question Regarding COPY Command Handling of Line Breaks in PostgreSQL

From: gzh <[email-masked]>
Date: Fri, 11 Jul 2025 20:20:38 +0800 (CST)

Dear,

I am encountering an issue with the COPY command in PostgreSQL regarding the handling of line breaks in data fields. My PostgreSQL instance is installed on a Linux system.

When I use the COPY command to export data to a CSV file and then import the same CSV file back into the database, all carriage return characters (CR) in the fields are automatically converted to line feed characters (LF). For example:

Field content before import: *** (CR) ***
Field content after import: *** (LF) ***
I would like to know if there is a way to use the COPY command while preserving the original line breaks (CR) in the data fields during import.

Thank you for your assistance.

Best regards,
gzh

---

From: Ron Johnson <[email-masked]>
Date: Fri, 11 Jul 2025 09:07:32 -0400

On Fri, Jul 11, 2025 at 8:20 AM gzh <[email-masked]> wrote:

> Dear,
>
> I am encountering an issue with the COPY command in PostgreSQL regarding
> the handling of line breaks in data fields. My PostgreSQL instance is
> installed on a Linux system.
>
> When I use the COPY command to export data to a CSV file and then import
> the same CSV file back into the database, all carriage return characters
> (CR) in the fields are automatically converted to line feed characters
> (LF). For example:
>
> I would like to know if there is a way to use the COPY command while
> preserving the original line breaks (CR) in the data fields during import.
>

What PG version?
What's the full command (including both shell and SQL commands)?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!