Subject: Re: Convert date and time colums to datetime

From: Rob Sargent <[email-masked]>
Date: Sun, 19 Oct 2025 20:32:07 -0600

> On Oct 19, 2025, at 2:38 PM, Rich Shepard <[email-masked]> wrote:
> 
> On Sun, 19 Oct 2025, Rob Sargent wrote:
> 
>> I think you have to ask why those values were separated in the first
>> place. For instance if they are thought of as a pair in most queries then
>> an alteration might be in order. There can be a large one time cost if
>> these tables occur in a lot of separate sql calls in the business logic.
> 
> Rob,
> 
> Good point. They're in the contacts table and I use them to determine when
> to make another contact and if prior contacts were more productive in the
> morning or afternoon.
> 
> Thanks,
> 
> Rich
> 
> 

Definitely a datetime (single value) problem, imho

---

From: Rich Shepard <[email-masked]>
Date: Mon, 20 Oct 2025 05:45:34 -0700 (PDT)

Rob,

Okay. Now I'm curious: why do you write this?

Thanks,

Rich

---

From: Rob Sargent <[email-masked]>
Date: Mon, 20 Oct 2025 06:53:08 -0600

> On Oct 20, 2025, at 6:45 AM, Rich Shepard <[email-masked]> wrote:
> 

The way I read your description of how you use these columns currently suggests to me that they could be handled by a single timestamp column. The cost/benefit of converting is another thing altogether.

---

From: Rich Shepard <[email-masked]>
Date: Mon, 20 Oct 2025 05:58:16 -0700 (PDT)

> The way I read your description of how you use these columns currently
> suggests to me that they could be handled by a single timestamp column.
> The cost/benefit of converting is another thing altogether.

Rob,

Since either way works I'll save the time cost of converting because my
tables will never be really large.

Thanks,

Rich

---

From: Ron Johnson <[email-masked]>
Date: Mon, 20 Oct 2025 09:00:19 -0400

> tables will never be really large.

Virtual columns exist: have both!

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Rob Sargent <[email-masked]>
Date: Mon, 20 Oct 2025 07:26:32 -0600

> On Oct 20, 2025, at 6:58 AM, Rich Shepard <[email-masked]> wrote:
> 

For sure! Your call