Subject: Re: To take backup of Postgresql Database without large objects

From: "[email-masked]" <[email-masked]>
Date: Fri, 11 Apr 2025 12:55:40 +0000 (UTC)

Hello,
Using PostgreSQL 15.1, compiled by Visual C++ build 1914, 64-bit in Windows 10.
Trying to take backup of a database, using pg_dump, where one table contains bytea datatype, which I don't want to include in the backup.
My command was:"E:\DBBackup\bin\pg_dump.exe"  -h 192.168.1.1 -p 5432 -U <username> --no-blobs -F c -v -f "E:\DBBackup\demo6_110420251637.bak" demo6 

the backup includes the bytea field also.  
I tried with "E:\DBBackup\bin\pg_dump.exe"  -h 192.168.1.1 -p 5432 -U <username> -B -F c -v -f "E:\DBBackup\demo6_110420251637.bak" demo6 

also, which also included the bytea field.
What wrong I'm doing?  Couldn't figure it out.   Any help is appreciated.
Happiness Always
BKR Sivaprakash

---

From: Ron Johnson <[email-masked]>
Date: Fri, 11 Apr 2025 09:29:07 -0400

> Using PostgreSQL 15.1, compiled by Visual C++ build 1914, 64-bit in

That's 11 patch releases behind current.

> Trying to take backup of a database, using pg_dump, where one table
> contains bytea datatype, which I don't want to include in the backup.
>
> My command was:
> "E:\DBBackup\bin\pg_dump.exe"  -h 192.168.1.1 -p 5432 -U <username>
> --no-blobs -F c -v -f "E:\DBBackup\demo6_110420251637.bak" demo6
>
> I tried with
> "E:\DBBackup\bin\pg_dump.exe"  -h 192.168.1.1 -p 5432 -U <username> -B -F
> c -v -f "E:\DBBackup\demo6_110420251637.bak" demo6
>

The manual explicitly states what you're doing wrong.
https://www.postgresql.org/docs/15/app-pgdump.html

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!