Subject: pgstattuple - can it/does it provide stats by partition?

From: Dragam <[email-masked]>
Date: Sat, 15 Jun 2024 12:40:31 +0000

Hi all,

As the title says - does (and/or can) pgstattuple provide a breakdown by partition?

Any further info needed, please let me know.

TIA and rgs,

Dragam

Envoyé avec la messagerie sécurisée [Proton Mail.](https://proton.me/)

---

From: Ron Johnson <[email-masked]>
Date: Sat, 15 Jun 2024 13:04:58 -0400

On Sat, Jun 15, 2024 at 9:47 AM Dragam <[email-masked]> wrote:

> <https://proton.me/>

Partitions are tables, created via CREATE TABLE.  I know from experience
that it works on inheritance tables; what happens when you try
pgstattuple() on a small test partition?