Subject: Issue installing postgis on RHEL9

From: Danny Im <[email-masked]>
Date: Wed, 2 Apr 2025 11:29:24 -0500

Hello,

I am having issues trying to install the postgis30_13 package on a RHEL9
host. Attempting to install the package gives me this error:

$ sudo dnf install postgis30_13
Updating Subscription Management repositories.
Zabbix 6.0 LTS RHEL9
                                      50 kB/s | 2.0 kB     00:00
EPEL 9
                                      52 kB/s | 2.3 kB     00:00
Red Hat Enterprise Linux 9 for x86_64 - BaseOS (RPMs)
                                     97 kB/s | 4.1 kB     00:00
Shibboleth RHEL9
                                      44 kB/s | 2.0 kB     00:00
umn-rhel9-internal
                                      52 kB/s | 2.0 kB     00:00
DUO Security RHEL 9
                                     68 kB/s | 2.7 kB     00:00
PagerDuty Zabbix Agent
                                      60 kB/s | 2.0 kB     00:00
Microsoft for RHEL9
                                     41 kB/s | 2.0 kB     00:00
Oracle Instant Client for OL9
                                     49 kB/s | 2.0 kB     00:00
Red Hat Enterprise Linux 9 for x86_64 - AppStream (RPMs)
                                     105 kB/s | 4.5 kB     00:00
Error:
 Problem: package postgis30_13-3.0.7-1.rhel9.x86_64 from postgresql
requires gdal33-libs >= 3.3.3, but none of the providers can be installed
  - package postgis30_13-3.0.7-1.rhel9.x86_64 from postgresql requires
libgdal.so.29()(64bit), but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides libarmadillo.so.10()(64bit) needed by
gdal33-libs-3.3.3-7PGDG.rhel9.x86_64 from postgresql-common
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
use not only best candidate packages)

I have epel enabled and the only version of armadillo available is
12.6.6-2.el9

Does anyone have any suggestions on how to resolve the issue?

-- 
Danny Im
Software Developer
Polar Geospatial Center
University of Minnesota

---

From: Ron Johnson <[email-masked]>
Date: Wed, 2 Apr 2025 12:32:34 -0400

On Wed, Apr 2, 2025 at 12:29 PM Danny Im <[email-masked]> wrote:

> (try to add '--skip-broken' to skip uninstallable packages or '--nobest'
> to use not only best candidate packages)
>

Are the missing packages in EPEL?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Danny Im <[email-masked]>
Date: Wed, 2 Apr 2025 12:12:35 -0500

It doesn't look like it.  I tried to find what provides libarmadillo.so.10
but could not find any packages:

$ sudo dnf provides */libarmadillo.so.10
Updating Subscription Management repositories.
Last metadata expiration check: 0:20:05 ago on Wed Apr  2 11:17:43 2025.
Error: No matches found. If searching for a file, try specifying the full
path or using a wildcard prefix ("*/") at the beginning.

The only version of armadillo available to me is 12.6.6-2.el9 which
provides libarmadillo.so.12

I assume I need an older version of armadillo, is there a particular repo
that I need to enable to get this particular dependency?

Thanks

-- 
Danny Im
Software Developer
Polar Geospatial Center
University of Minnesota

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 02 Apr 2025 21:29:25 +0300

Hi,

> Updating Subscription Management repositories.

<snip>

> Does anyone have any suggestions on how to resolve the issue?

I haven't been maintaining PostGIS 3.0 RPMs for a while. Let me look.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR