Subject: PostgreSQL logical replication

From: Jayadevan M <[email-masked]>
Date: Tue, 12 Nov 2024 16:16:21 +0530

Hello all,

I am using PostgreSQL 16.4. I tried to set up logical replication with
"postgres" user and all worked fine.  Then I created a new user
(my_replication) to be used for the purpose and couldn't figure out which
privileges are necessary. Initially I got an error like "ERROR:  permission
denied for database mydb" . So I used GRANT CREATE ON DATABASE..and that
error disappeared. I have also executed...
ALTER USER my_replication WITH replication;
GRANT usage ON SCHEMA public TO my_replication;
GRANT SELECT ON ALL TABLES IN SCHEMA public TO my_replication;
When I try
 CREATE PUBLICATION my_publication for table public.term;
I am getting an error
ERROR:  must be owner of table term

What privileges should be granted so that I can do
 CREATE PUBLICATION my_publication FOR TABLES IN SCHEMA public;

Regards,
Jayadevan

---

From: Ron Johnson <[email-masked]>
Date: Tue, 12 Nov 2024 09:16:54 -0500

The documentation tells you, down in the Notes section.

https://www.postgresql.org/docs/16/sql-createpublication.html

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!