Subject: What is the best way to upgrade pgAdmin on Windows?

From: 毛毛 <[email-masked]>
Date: Thu, 15 Aug 2024 14:34:59 +0800 (CST)

Hey there,

I just found out my pgAdmin is version 7.6, while the current version is 8.6. Looks like it's time for an upgrade!

The notification I got had a link to the EDB site with a bunch of PostgreSQL installers listed. Thing is, I don't want to mess up my database. So I figured it'd be smart to learn some best practices for upgrading before I dive in.

Any tips or advice on how to do this safely? Thanks in advance!

---

From: Ron Johnson <[email-masked]>
Date: Thu, 15 Aug 2024 09:56:39 -0400

On Thu, Aug 15, 2024 at 2:35 AM 毛毛 <[email-masked]> wrote:

> Hey there,
>
> I just found out my pgAdmin is version 7.6, while the current version is
> 8.6. Looks like it's time for an upgrade!
>

https://www.pgadmin.org/download/pgadmin-4-windows/

The latest is 8.10.

> The notification I got had a link to the EDB site with a bunch of
> PostgreSQL installers listed. Thing is, I don't want to mess up my
> database.
>

What does PgAdmin have to do with your database?

(Unless EDB only bundles *everything* together, in which case you should *ask
EDB*.)

> So I figured it'd be smart to learn some best practices for upgrading
> before I dive in.
>

I'd install 8.10 from
https://www.postgresql.org/ftp/pgadmin/pgadmin4/v8.10/windows/, and expect
it to overwrite the old version, just like every other Windows and Linux
installer does.

-- 
Death to America, and butter sauce.
Iraq lobster!

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 15 Aug 2024 07:31:01 -0700

> 8.6. Looks like it's time for an upgrade!

Per

The current version is 8.10.

> database. So I figured it'd be smart to learn some best practices for 
> upgrading before I dive in.

pgAdmin4 != Postgres, it is just a GUI client for Postgres.

How did you originally install pgAdmin4?

-- 
Adrian Klaver
[email-masked]

---

From: 毛毛 <[email-masked]>
Date: Fri, 16 Aug 2024 13:02:07 +0800 (CST)

Hi Ron,
 
The notification I got had a link to the EDB site with a bunch of PostgreSQL installers listed. Thing is, I don't want to mess up my database.

I didn't know there was a standalone installer for pgAdmin.

This link brought me to this page: https://www.enterprisedb.com/downloads/postgres-postgresql-downloads
I could not find a standalone installer for pgAdmin so I thought I can only upgrade via one of the all-in-one installer.

Hi Adrian,

How did you originally install pgAdmin4?
I started by clicking Download the installer on this page: PostgreSQL: Windows installers 
I ran the installer downloaded and checked the box for pgAdmin during the installation.

Hi Anthony,

If your version of pgAdmin was installed while you installed PostgreSQL itself via the EDB installer for Windows, then the easiest upgrade option is to navigate under Start to Uninstall Programs and choose to uninstall PostgreSQL.

When the uninstaller fires up, it should give you the option to specify which components to uninstall. You can choose to uninstall ONLY pgAdmin.

I do this often and have never had an issue. It avoids getting two versions of pgAdmin on your Windows machine.

This is exactly what I did. I carried out the installation exactly as described in your book.
What should I do after the uninstallation? Should I download and run installer available on: Download (pgadmin.org)

Thank you!

At 2024-08-16 04:38:26, "Anthony DeBarros" <[email-masked]> wrote:

Howdy,

Hey there,

If your version of pgAdmin was installed while you installed PostgreSQL itself via the EDB installer for Windows, then the easiest upgrade option is to navigate under Start to Uninstall Programs and choose to uninstall PostgreSQL.

When the uninstaller fires up, it should give you the option to specify which components to uninstall. You can choose to uninstall ONLY pgAdmin.

I do this often and have never had an issue. It avoids getting two versions of pgAdmin on your Windows machine.

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 16 Aug 2024 16:14:02 -0700

> I started by clicking Download the installer 
> <https://www.enterprisedb.com/downloads/postgres-postgresql-downloads> on this page: PostgreSQL: Windows installers <https://www.postgresql.org/download/windows/>

1) Do you want to have the Postgres server running on your Windows 
machine or do you want to just have pgAdmin4 installed?

2) If you want to have the Postgres server installed I would say you 
need to keep up with the minor version releases of whatever Postgres 
version you have installed. For example for Postgres 16 that would be 
16.4. If I remember correctly that will update the pgAdmin4 version.