Subject: Archive logging not cleaning up pg_wal directory

From: Justin Swanhart <[email-masked]>
Date: Thu, 10 Apr 2025 08:28:36 -0400

Hi,

I have the following in my postgresql.conf for archive logging:
archive_command='test ! -f /var/lib/postgresql/prod_archive_logs/%f && cp
%p /var/lib/postgresql/prod_archive_logs/%f'

This command is properly copying the log files to my archive directory but
they remain in the `pg_wal` directory after they are copied, consuming
hundreds of gigs of space.  Am I supposed to create a cron job to clean out
the `pg_wal` directory periodically (keep only 1 day of logs I guess?)

I tried to use mv:
archive_command='test ! -f /var/lib/postgresql/prod_archive_logs/%f && mv
%p /var/lib/postgresql/prod_archive_logs/%f'

When I did this the archives were moved away to the archive directory but
when I tried to set up replication the server could not find the archived
log to replicate from so I changed it to "cp" and now have this problem.

What am I missing?

Regards,

--Justin

---

From: Laurenz Albe <[email-masked]>
Date: Thu, 10 Apr 2025 14:48:00 +0200

On Thu, 2025-04-10 at 08:28 -0400, Justin Swanhart wrote:
> archive_command='test ! -f /var/lib/postgresql/prod_archive_logs/%f && cp %p /var/lib/postgresql/prod_archive_logs/%f'
> 
> This command is properly copying the log files to my archive directory but they remain in the `pg_wal`
> directory after they are copied, consuming hundreds of gigs of space.  Am I supposed to create a cron
> job to clean out the `pg_wal` directory periodically (keep only 1 day of logs I guess?)
> 
> I tried to use mv:
> archive_command='test ! -f /var/lib/postgresql/prod_archive_logs/%f && mv %p /var/lib/postgresql/prod_archive_logs/%f'
> 
> When I did this the archives were moved away to the archive directory but when I tried to set up
> replication the server could not find the archived log to replicate from so I changed it to "cp" and now have this problem.
> 
> What am I missing?

Something else is blocking WAL removal:
https://www.cybertec-postgresql.com/en/why-does-my-pg_wal-keep-growing/

Since you mention replication, my money is on a stale replication slot.

Yours,
Laurenz Albe

---

From: Ron Johnson <[email-masked]>
Date: Thu, 10 Apr 2025 08:48:16 -0400

> the `pg_wal` directory periodically (keep only 1 day of logs I guess?)

No.  Definitely not.

> log to replicate from so I changed it to "cp" and now have this problem.

PG retains WAL files when it thinks it needs them.  "Orphaned replication
slot" is the typical reason.

Maybe you tried to set up replication at some point in the past, but
then forgot to drop the slot?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!