Subject: Re: Why isn't my table auto-analyzed/vacuumed?

From: Dimitrios Apostolou <[email-masked]>
Date: Thu, 30 Oct 2025 19:41:39 +0100 (CET)

On Thursday 2025-10-30 18:00, Ron Johnson wrote:

>On Thu, Oct 30, 2025 at 11:55 AM Dimitrios Apostolou <[email-masked]> wrote:

>      > SELECT name,setting FROM pg_settings WHERE name ILIKE '%factor%' ;
>                        name                  | setting
>      ---------------------------------------+---------
>        autovacuum_analyze_scale_factor       | 0.1
>
>
>0.1 means 10%.

Thank you Ron! I was quite sure 0.1 meant 1/1000 because of this:

SELECT min_val,max_val FROM pg_settings WHERE name = 'autovacuum_analyze_scale_factor' \gx

-[ RECORD 1 ]
min_val | 0
max_val | 100

I will adjust the values accordingly and check back. Cheers!

Dimitris

---

From: Ron Johnson <[email-masked]>
Date: Thu, 30 Oct 2025 14:46:17 -0400

> 'autovacuum_analyze_scale_factor' \gx

https://www.postgresql.org/docs/17/runtime-config-autovacuum.html#GUC-AUTOVACUUM-ANALYZE-SCALE-FACTOR
"Specifies a fraction of the table size to add to
autovacuum_analyze_threshold when deciding whether to trigger an ANALYZE.
The default is 0.1 (10% of table size)."

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!