Subject: Guidance on PgSql Upgrade from 17.3 to 18.2

From: Pratibha Shende <[email-masked]>
Date: Wed, 11 Mar 2026 13:49:18 +0530

Hello Team,

I am planning to upgrade PostgreSQL from 17.3 to 18.2 and would like your
guidance on the key considerations before proceeding.

Could you please advise on:

1.Important points to consider during the upgrade.
2. Features deprecated or removed between these versions.

Any best practices or compatibility recommendations would be appreciated.

*Thanks and Regards*
*Pratibha Shivaji Shende*

---

From: Ron Johnson <[email-masked]>
Date: Wed, 11 Mar 2026 09:04:17 -0400

> Any best practices or compatibility recommendations would be appreciated.

1. Read the release notes. https://www.postgresql.org/docs/release/18.0/
2. Update the existing instance to 17.9 beforehand.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!