Subject: Database in another drive

From: Arbol One <[email-masked]>
Date: Mon, 13 Oct 2025 20:19:01 +0000

Is there a way to either create the database or save the data in another drive?

I am using Win11, not my choice since 1998, and, not surprisingly, the WinOS had a crash; I lost all kinds of information including PostgreSQL (postgres (PostgreSQL) 18.0), its databases, tables, data, etc., what a nightmare!
To not have this happen again, I'd like to create the databases in the E: drive or have the tables stored in that drive, please note that I am not talking about backing the data in the E: drive, but to actually have the databases in the E: drive. Can this be done and is it practical to do this?

---

From: John McKown <[email-masked]>
Date: Mon, 13 Oct 2025 15:21:45 -0500

https://www.google.com/search?q=create+postgres+database+on+e%3A&oq=create+postgres+database+on+e%3A&gs_lcrp=EgZjaHJvbWUyBggAEEUYOdIBCTI5MjI0ajBqN6gCD7ACAQ&client=ms-android-google&sourceid=chrome-mobile&ie=UTF-8

On Mon, Oct 13, 2025, 15:19 Arbol One <[email-masked]> wrote:

> I am using Win11, not my choice since 1998, and, not surprisingly, the
> WinOS had a crash; I lost all kinds of information including PostgreSQL (postgres
> (PostgreSQL) 18.0), its databases, tables, data, etc., what a nightmare!
> To not have this happen again, I'd like to create the databases in the E:
> drive or have the tables stored in that drive, please note that I am not
> talking about backing the data in the E: drive, but to actually have the
> databases in the E: drive. Can this be done and is it practical to do this?
>
>
>
>
>
>
>

---

From: Tim Gerber <[email-masked]>
Date: Mon, 13 Oct 2025 15:36:46 -0500

Yes, you can either set the default tablespace to the desired drive or
create a tablespace on the E: drive and specify the db objects to use it.
Best to look at:
https://www.postgresql.org/docs/current/manage-ag-tablespaces.html

Best Regards,
Tim

---

From: Ron Johnson <[email-masked]>
Date: Mon, 13 Oct 2025 17:57:53 -0400

On Mon, Oct 13, 2025 at 4:19 PM Arbol One <[email-masked]> wrote:

> WinOS had a crash;

I've been using Windows on (local, telecommuting) corporate PCs for 25
years.  Never has the hardware crashed or Windows become so corrupted that
C: needed to be wiped?

> I lost all kinds of information including PostgreSQL (postgres

Where are your backups?  Why don't you have backups?

> databases in the E: drive. Can this be done and is it practical to do this?

Of course.  The same way you created them on C:.  Either with a GUI or
command prompt.
mkdir E:\PosgreSQL\data
initdb -k -D  E:\PosgreSQL\data

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 13 Oct 2025 16:01:57 -0700

On 10/13/25 14:57, Ron Johnson wrote:
> On Mon, Oct 13, 2025 at 4:19 PM Arbol One <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     I am using Win11, not my choice since 1998, and, not surprisingly,
>     the WinOS had a crash;
> 
> 
> years.  Never has the hardware crashed or Windows become so corrupted 
> that C: needed to be wiped?

Consider yourself having lived a charmed life. You don't want to have to 
restore a Windows machine. The usual method is to start over with an OS 
only disk image and rebuild the user data from backups.

-- 
Adrian Klaver
[email-masked]