Subject: Duplicate Key Values

From: mark bradley <[email-masked]>
Date: Wed, 5 Mar 2025 17:35:50 +0000

Although I did not enter them, somehow duplicate primary key values have appeared in one of my tables.  I can't remove the offending rows because the key is a foreign key in another table.

What to do?

Mark Brady,
amazon.com/author/markjbrady<https://amazon.com/author/markjbrady>

---

From: Ron Johnson <[email-masked]>
Date: Wed, 5 Mar 2025 12:50:13 -0500

On Wed, Mar 5, 2025 at 12:36 PM mark bradley <[email-masked]>
wrote:

> Although I did not enter them, somehow duplicate primary key values have
> appeared in one of my tables.
>

Is it a text/varchar column?  Has the distro been upgraded "recently", or
maybe streamed from an older Linux system to a newer Linux system?

> I can't remove the offending rows because the key is a foreign key in
> another table.
>
> What to do?
>

Are the records completely (i.e., all columns) identical?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!