Subject: Configure autovacuum

From: "Shenavai, Manuel" <[email-masked]>
Date: Fri, 14 Jun 2024 06:20:11 +0000

Hi everyone,

I would like to configure the autovacuum in a way that it runs very frequently (i.e. after each update-statement). I tried the following settings on my table:
alter table mytable set (autovacuum_vacuum_scale_factor  = 0.0);
alter table mytable set (autovacuum_vacuum_cost_delay  = 0.0);
alter table mytable set (autovacuum_vacuum_cost_limit  = 10000);
alter table mytable set (autovacuum_vacuum_threshold  = 1);

I do a lot of updates on a single tuple and I would expect that the autovacuum would start basically after each update (due to autovacuum_vacuum_threshold=1). But the autovacuum is not running.

Is it possible to configure postgres to autovacuum very aggressively (i.e. after each update-statement)?

Thanks in advance &
Best regards,
Manuel

---

From: Ron Johnson <[email-masked]>
Date: Fri, 14 Jun 2024 05:17:36 -0400

On Fri, Jun 14, 2024 at 2:20 AM Shenavai, Manuel <[email-masked]>
wrote:

> Hi everyone,
>
>
>
> I would like to configure the autovacuum in a way that it runs very
> frequently (i.e. after each update-statement). I tried the following
> settings on my table:
>
> I do a lot of updates on a single tuple and I would expect that the
> autovacuum would start basically after each update (due to
> autovacuum_vacuum_threshold=1). But the autovacuum is not running.
>

HOT is probably what you're looking for:
https://www.postgresql.org/docs/14/storage-hot.html

Presuming that the field you're updating is not indexed, and the table can
be exclusively locked for as long as it takes to rewrite it: give the table
"more space to work" in each page:
ALTER TABLE foo SET (fillfactor = 30);
VACUUM FULL foo;

Then you don't need to VACUUM soooo frequently.