Subject: postgres in swap space

From: Marc Millas <[email-masked]>
Date: Mon, 17 Nov 2025 18:25:14 +0100

hello,
Can someone point me to any doc describing why and how much space postgres
uses on the swap of a debian machine ?
it's an old postgres 10, because it is used by a product for which only
this version is certified.
(no comment on that, please)

regards

Marc MILLAS
Senior Architect
+33607850334
www.mokadb.com

---

From: Ron Johnson <[email-masked]>
Date: Mon, 17 Nov 2025 13:16:14 -0500

> (no comment on that, please)

Swap as in RAM swap space?  If so, then it uses as much or as little as
Linux thinks needs to be used, given the amount of RAM.

effective_cache_size, work_mem, shared_buffers,
maintenance_work_mem, max_worker_* and max_parallel_* affect how much RAM
PG uses, in conjunction with the number of active connections (including
maintenance work).

https://postgresqlco.nf/doc/en/param/ is a handy resource.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: [email-masked]
Date: Mon, 17 Nov 2025 15:23:45 -0500

Putting memory pages to swap is the decision of the linux virtual memory 
manager not postgres.  If your db machine is swapping, first make sure 
you have set sensible values for the ram related settings like 
shared_buffers (25%), effective_cache_size (75%) and work_mem (keep it 
modest at 4 to 16 MB).

On 11/17/25 12:25 PM, Marc Millas - marc.millas at mokadb.com wrote:
> hello,
> Can someone point me to any doc describing why and how much space 
> postgres uses on the swap of a debian machine ?
> it's an old postgres 10, because it is used by a product for which 
> only this version is certified.
> www.mokadb.com <http://www.mokadb.com>
>
-- 
regards,
Kiriakos Georgiou