Subject: Re: Corruption of few tables

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Feb 2025 07:21:14 +0000 (UTC)

Since we rectified the issue in ver 11, I couldn't get more details.   
Now we are getting the same [ or similar ] issue in PostgreSQL 15.7 (Ubuntu 15.7-1.pgdg24.04+1) on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 13.2.0-23ubuntu4) 13.2.0, 64-bit
When we ran the following query, in PGAdmin
Select releasenumber, buildnumberFrom   public.co_versionWhere  modulename = 'ALL';
We got the following errorERROR: SSL error: bad lengthSSL SYSCALL error: No error (0x00000000/0)
When we try to run the same above query by opening another window [ same PGAdmin, in another window ], we get correct expected result and NOT the error.
Couldn't identify whether this is related to network or corruption.  
Happiness Always
BKR Sivaprakash
    On Wednesday 26 February, 2025 at 12:07:00 pm IST, [email-masked] <[email-masked]> wrote:  
 
  Yes, we are planning to upgrade to Ver 17 soon.Yesterday, we got the similar error in one more client place where version 15 is running in Ubuntu Server.   We are trying to figure out whether it's a network issue or corruption issue.   
    On Tuesday 25 February, 2025 at 08:24:44 pm IST, Adrian Klaver <[email-masked]> wrote:  
 
 On 2/25/25 04:39, o1bigtenor wrote:
> On Tue, Feb 25, 2025 at 6:03 AM [email-masked]

> Not really a direct answer - - - but - - - have you considered
> updating Postgresql.
> Version 11 was EOL (end of life) over a year ago. Version 17 according
> to the charts I've found
> is the current version.

Actually the current community supported versions are 13-17.

The time lines for support can be found here:

https://www.postgresql.org/support/versioning/

> HTH

-- 
Adrian Klaver
[email-masked]

---

From: Greg Sabino Mullane <[email-masked]>
Date: Wed, 26 Feb 2025 09:06:08 -0500

On Wed, Feb 26, 2025 at 2:21 AM [email-masked] <
[email-masked]> wrote:

> issue in PostgreSQL 15.7

Still missing a ton of bug fixes - Postgres 15 is on version 15.12. Try to
get that upgraded.

> We got the following error
> ERROR: SSL error: bad length
> SSL SYSCALL error: No error (0x00000000/0)
>

This is a network error, not data corruption. How much time passes from
starting the query until you see the error? Make sure all your related
programs are up to date (esp. pgadmin, openssl). Check the Postgres logs to
see if there is more information or perhaps other information about why the
SSL connection is failing.

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support

---

From: Ron Johnson <[email-masked]>
Date: Wed, 26 Feb 2025 09:28:57 -0500

> Still missing a ton of bug fixes - Postgres 15 is on version 15.12. Try to

And it takes less than five minutes to stop the instance, install the
packages then restart the instance.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!