Subject: Re: glibc updarte 2.31 to 2.38

From: Joe Conway <[email-masked]>
Date: Sun, 22 Sep 2024 09:47:04 -0400

On 9/21/24 15:19, Paul Foerster wrote:
> I already expressed the idea of changing all locales to ICU. The
> problem there is that I'd have to create new instances and then move
> each database individually. I wish I could convert already running
> databases… This also takes time. Still, I think I'm going to try
> this route. It's always a gamble if reindexing is needed or not with
> any glibc change.

Note that moving to ICU might improve things, but there are similar 
potential issues with ICU as well. The trick there would be to get your 
OS distro provider to maintain the same ICU version across major 
versions of the distro, which is not the case currently. Nor does the 
PGDG repo do that.

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: Shaheed Haque <[email-masked]>
Date: Sun, 22 Sep 2024 14:59:34 +0100

I've been working on Unix-like systems for decades and though I thought I
understood most of the issues to do with i18n/l10n, I've only just started
using Postgres and I don't understand is why these changes ONLY seem to
affect Postgres. Or is it more that it also affects text editors and the
like, but we just tend to ignore that?

---

From: Ron Johnson <[email-masked]>
Date: Sun, 22 Sep 2024 10:11:00 -0400

Shaheed,

How often do you sort words in text editors?
How often do you have your text editor care whether the word you just typed
is the *only* instance of that word in the document?

Not too often.  So... yes, we ignore the problem.

The real question is why nobody notices it in other RDBMSs like Oracle, SQL
Server and MySQL.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> crustacean!

---

From: Karsten Hilbert <[email-masked]>
Date: Sun, 22 Sep 2024 16:16:52 +0200

> like, but we just tend to ignore that?

Text editors for example do not persist ordering based on locale.

I'm sure there's software ignoring the issue, too.

Karsten
--
GPG  40BE 5B0E C98E 1713 AFA6  5BC0 3BEA AC80 7D4F C89B

---

From: Paul Förster <[email-masked]>
Date: Sun, 22 Sep 2024 18:52:30 +0200

Hi Ron,

> On 22. Sep, 2024, at 16:11, Ron Johnson <[email-masked]> wrote:
> 
> The real question is why nobody notices it in other RDBMSs like Oracle, SQL Server and MySQL.

The answer is simple for Oracle: It includes a whole zoo of locale mappings and uses each one as it is needed. This is one of the many things with Oracle that only grows over time but does never get smaller again.

I suspect it's similar with MariaDB, MySQL, SQL Server and others. Only PostgreSQL has no such thing as a local inventory and relies on either glibc or ICU.

Cheers,
Paul