Subject: Re: Issue installing postgis on RHEL9

From: Devrim Gündüz <[email-masked]>
Date: Wed, 02 Apr 2025 21:48:19 +0300

Hi,

On Wed, 2025-04-02 at 11:29 -0500, Danny Im wrote:
> Problem: package postgis30_13-3.0.7-1.rhel9.x86_64 from postgresql
> requires gdal33-libs >= 3.3.3, but none of the providers can be
> installed
>   - package postgis30_13-3.0.7-1.rhel9.x86_64 from postgresql requires
> libgdal.so.29()(64bit), but none of the providers can be installed
>   - cannot install the best candidate for the job
>   - nothing provides libarmadillo.so.10()(64bit) needed by
> gdal33-libs-3.3.3-7PGDG.rhel9.x86_64 from postgresql-common
> (try to add '--skip-broken' to skip uninstallable packages or '--
> nobest' to
> use not only best candidate packages)

Fixed in 3.0.9-2. Please make sure that you update repository cache
first to receive the updates.

Regards,

-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Danny Im <[email-masked]>
Date: Wed, 2 Apr 2025 14:13:25 -0500

I have confirmed that the package installs successfully, thank you!

-- 
Danny Im
Software Developer
Polar Geospatial Center
University of Minnesota