Subject: Alignment check

From: Marthin Laubscher <[email-masked]>
Date: Thu, 27 Jun 2024 18:07:53 +0200

Hi,

I don’t intend dissing or plugging anyone’s efforts or start a flame war, but I’d like to get a sense of how the PostgreSQL community feels about:
a) YugabyteDB, and
b) PostgreSQL on Kubernetes.

For my application I’m deeply vested in Kubernetes as a pathway to being cloud-agnostic and I have looked at YugabyteDB because it matches my application’s (distributed) architecture more closely. 
But not all the ways to run PostgreSQL on Kubernetes are created equal, and YugabyteDB is really far behind on versions and do not support extensions in a way that’s useful to me. 

So seeing that I’ve taken the plunge to join the mailing lists at least I’d love to hear any and all feedback on those two topics from the these parts of the woods.

 --- Thanks for your time – Marthin Laubscher

---

From: Michael Nolan <[email-masked]>
Date: Sat, 6 Jul 2024 08:50:42 -0500

I don't have any direct experience with Yugabyte (the databases I work
with are way too small to be on Yugabyte) but my older son does work
for them as an SRE, sometimes remotely when he's visiting us, so we've
talked about it a bit.  (It's actually the first time in 20 years I've
had much of a clue about what he's working with.)