Subject: Creating a new database on a different file system

From: Ian Dauncey <[email-masked]>
Date: Mon, 17 Mar 2025 14:48:42 +0000

Hi All

We are running an old version of PostgreSQL on a Linux Server.
We have created a few databases on the file system defined in the postgresql.conf, but now I would like to create another database within the same cluster but on a different file system.
Is this possible and if so, how do we go about it.

In a nutshell:

I have the following statement defined in the postgresql.conf file - data_directory = '/opt/pgdata_postgres'

I have created the following database datadb1, datadb2 (plus all default databases)

Now I want to create a third database datadb3, but it needs to be created on file system "/opt/pgdata1_postgres"  and not on '/opt/pgdata_postgres'

Is this possible

Regards
Ian

---

From: Tim Gerber <[email-masked]>
Date: Mon, 17 Mar 2025 09:51:55 -0500

Hi Ian,

Tablespaces would work... take a look:
https://www.postgresql.org/docs/current/manage-ag-tablespaces.html

Best,
Tim

On Mon, Mar 17, 2025 at 9:49 AM Ian Dauncey <[email-masked]>
wrote:

> We have created a few databases on the file system defined in the
> postgresql.conf, but now I would like to create another database within the
> same cluster but on a different file system.
>
> Now I want to create a third database datadb3, but it needs to be created
> on file system “/opt/pgdata1_postgres”  and not on ‘/opt/pgdata_postgres'
>
>
>
> Is this possible
>
>
>
> Regards
>
> Ian
>
>
>
>
>