Subject: old OS

From: Marc Millas <[email-masked]>
Date: Tue, 4 Feb 2025 18:49:41 +0100

Hi,

I need to install psql on a redhat 6.5 Linux, to transfert local data to a
distant
 postgreSQL 16 DB.
Too my understanding, as this redhat version is EOL for long, No such psql
is available.

My question is: is there any possibility to find something ?
and/or what is the latest psql available on a redhat 6.5 ?

If nothing, I will try to pipe the data directly through the network
connection, but this generates other problems.

thanks for your help

Marc MILLAS
Senior Architect
+33607850334

---

From: Christophe Pettus <[email-masked]>
Date: Tue, 4 Feb 2025 09:54:19 -0800

> On Feb 4, 2025, at 09:49, Marc Millas <[email-masked]> wrote:

Although I've not done so, it should be possible to build from source even on a system that old.

---

From: Tim Gerber <[email-masked]>
Date: Tue, 4 Feb 2025 12:04:42 -0600

Appears PG 12 is available for RHEL 6 via the following repository:

 https://download.postgresql.org/pub/repos/yum/12/redhat/
<https://download.postgresql.org/pub/repos/yum/12/redhat/>

If you need more reference, take a look at:
 https://www.postgresql.org/download/linux/redhat/
<https://www.postgresql.org/download/linux/redhat/>

Hope this helps,
Tim

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Feb 2025 10:06:55 -0800

On 2/4/25 09:49, Marc Millas wrote:
> Hi,
> 
> I need to install psql on a redhat 6.5 Linux, to transfert local data to 
> a distant
>   postgreSQL 16 DB.
> Too my understanding, as this redhat version is EOL for long, No such 
> psql is available.

There are the PGDG archive repos:

https://yum.postgresql.org/repopackages/#pgredhatoldrepos

For RH 6.* looks like it goes up to Postgres 11.

-- 
Adrian Klaver
[email-masked]