Subject: MError after replication in postgresql

From: Danish Hajwane <[email-masked]>
Date: Wed, 25 Sep 2024 10:57:10 +0530

Hi Team,

We are getting error after doing replication on posrgresql 16.3 (OS is HP
UX)
error is regarding Libpq library, we are unable to start sync getting error

FATAL: could not connect to the primary server : libpq is incorrectly
linked to backend functions.
LOG: waiting for WAL to become available at 0/36000018.

Regards
Danish

---

From: Muhammad Usman Khan <[email-masked]>
Date: Thu, 26 Sep 2024 08:34:27 +0500

Hi,
There are many causes of this issue. One possible solution to handle this
issue is to make sure that proper dynamic linking as follows:

export LD_LIBRARY_PATH=/path/to/pgsql/lib:$LD_LIBRARY_PATH