Subject: CREATE DATABASE command concurrency

From: Wizard Brony <[email-masked]>
Date: Tue, 17 Sep 2024 17:52:58 -0400

What are the concurrency guarantees of the CREATE DATABASE command? For example, is the CREATE DATABASE command safe to be called concurrently such that one command succeeds and the other reliably fails without corruption?

---

From: Muhammad Usman Khan <[email-masked]>
Date: Thu, 19 Sep 2024 08:53:13 +0500

Hi,
In PostgreSQL, it's safe to run CREATE DATABASE at the same time from
different places. If two commands try to create the same database, one will
succeed, and the other will safely fail without causing any problems or
incomplete database creation.

On Wed, 18 Sept 2024 at 19:08, Wizard Brony <[email-masked]> wrote:

> What are the concurrency guarantees of the CREATE DATABASE command? For
> example, is the CREATE DATABASE command safe to be called concurrently such
> that one command succeeds and the other reliably fails without corruption?
>
>
>