Subject: where is postres installed?

From: Arbol One <[email-masked]>
Date: Thu, 22 Aug 2024 20:35:39 -0400

After installing PostgreSQL on my Debian-12 machine, I typed 'postgres 
--version' and got this msg:
*bash: postgres: command not found*

'psql --version', however, does work and gives me this message :

*psql (PostgreSQL) 16.3 (Debian 16.3-1.pgdg120+1)*

Obviously postgres is not in the path, but I don't know where the 
'apt-get' installed it or why it did not add it to the path.

Is there a way I can locate the installation directory?

Thank in advance.

-- 
*/ArbolOne.ca/* Using Fire Fox and Thunderbird. ArbolOne is composed of 
students and volunteers dedicated to providing free services to 
charitable organizations. ArbolOne on Java Development is in progress [ í ]

---

From: Muhammad Usman Khan <[email-masked]>
Date: Fri, 23 Aug 2024 09:32:54 +0500

Hi Arbol,

You can try from the following commands:

dpkg-query -L postgresql-16
which psql
sudo find / -name "postgres" 2>/dev/null

On Fri, 23 Aug 2024 at 05:35, Arbol One <[email-masked]> wrote:

> *ArbolOne.ca* Using Fire Fox and Thunderbird. ArbolOne is composed of
> students and volunteers dedicated to providing free services to charitable
> organizations. ArbolOne on Java Development is in progress [ í ]
>

---

From: Muhammad Ikram <[email-masked]>
Date: Fri, 23 Aug 2024 09:49:44 +0500

Hi Arbol,

Hope above response from Usman must have resolved your issue. You may also
try by finding any  binary of PostgreSQL. e.g.

 find /usr -name pg_ctl
/usr/local/pgsql/bin/pg_ctl
/usr/lib/postgresql/16/bin/pg_ctl

Regards,
Ikram

-- 
Muhammad Ikram

---

From: Ron Johnson <[email-masked]>
Date: Fri, 23 Aug 2024 01:21:39 -0400

> Is there a way I can locate the installation directory?

pg_config | grep BINDIR

-- 
Death to America, and butter sauce.
Iraq lobster!

---

From: Kashif Zeeshan <[email-masked]>
Date: Fri, 23 Aug 2024 10:23:43 +0500

Hi Arbol

Use this command and it will show all the files installed by the package.

Regards

Kashif Zeeshan