Subject: Postgres_FDW doc doesn't specify TYPE support in Remote Execution Options

From: Rajan Pandey <[email-masked]>
Date: Tue, 9 Apr 2024 15:49:39 +0530

Hi,
I was reading
https://www.postgresql.org/docs/current/postgres-fdw.html#POSTGRES-FDW-OPTIONS-REMOTE-EXECUTION
and
found that it mentions that Immutable Functions and Operators can be pushed
down using `extensions` option for foreign server.

But it does not mention about TYPE. In the shippable.c
<https://doxygen.postgresql.org/shippable_8c_source.html>/lookup_shippable()
function, I found that type is also pushed down.

Does this require updating the docs? Can I raise a PR to do so? Thank you!
:)

-- 
Regards
Rajan Pandey

---

From: Laurenz Albe <[email-masked]>
Date: Tue, 09 Apr 2024 12:36:08 +0200

On Tue, 2024-04-09 at 15:49 +0530, Rajan Pandey wrote:
> I was reading https://www.postgresql.org/docs/current/postgres-fdw.html#POSTGRES-FDW-OPTIONS-REMOTE-EXECUTION
> and found that it mentions that Immutable Functions and Operators can
> be pushed down using `extensions` option for foreign server.
> 
> But it does not mention about TYPE. In the shippable.c/lookup_shippable()

The comment only says that data types may be shippable, but not that
they are actually shipped.  Can you think of a case where a data type
would be shipped to a foreign server?  I wrote a foreign data wrapper,
and I cannot think of such a case.

Perhaps the function comment should be adjusted by removing the parenthesis
or changing it to "(operator/function/...)".

> Does this require updating the docs? Can I raise a PR to do so? Thank you! :) 

You would send a patch against the "master" branch to the pgsql-docs list for that.

Yours,
Laurenz Albe