Subject: Re: glibc updarte 2.31 to 2.38

From: "Peter J. Holzer" <[email-masked]>
Date: Sat, 21 Sep 2024 00:33:16 +0200

On 2024-09-19 20:12:13 +0200, Paul Foerster wrote:
> Hi Peter,
> > On 19 Sep 2024, at 19:43, Peter J. Holzer <[email-masked]> wrote:
> > 
> > I wrote a small script[1] which prints all unicode code points and a few
> > selected[2] longer strings in order. If you run that before and after
> > the upgrade and the output doesn't change, you are probably be fine.
[caveats]
> > 
> > [1] https://git.hjp.at:3000/hjp/pgcollate
> > [2] The selection is highly subjective and totally unscientific.
> >    Additions are welcome.
> 
> I'm not a Python specialist but I take it that the script need
> psycopg2, which we probably don't have. So I'd have to build some sort
> of venv around that like I had to do to get Patroni working on our
> systems.

I don't use SLES but I would expect it to have an RPM for it.

If you have any test machine which you can upgrade before the production
servers (and given the amount of data and availability requirements you
have, I really hope you do) you should be set.

        hp

-- 
   _  | Peter J. Holzer    | Story must make more sense than reality.
|_|_) |                    |
| |   | [email-masked]         |    -- Charles Stross, "Creative writing
__/   | http://www.hjp.at/ |       challenge!"

---

From: Paul Foerster <[email-masked]>
Date: Sat, 21 Sep 2024 21:19:32 +0200

Hi Peter,

> On 21 Sep 2024, at 00:33, Peter J. Holzer <[email-masked]> wrote:
> 

One of our admins did me a favor and upgraded my build server ahead of schedule. So I can both test our current PostgreSQL version as well as rebuild it if necessary.

I can't test all of our data. That'd take quite a few months or more. I just can try to identify some crucial databases and columns. When those tests are done, I can only pray and hope for the best.

I already expressed the idea of changing all locales to ICU. The problem there is that I'd have to create new instances and then move each database individually. I wish I could convert already running databases… This also takes time. Still, I think I'm going to try this route. It's always a gamble if reindexing is needed or not with any glibc change.

Cheers,
Paul